summaryrefslogtreecommitdiff
path: root/dev-python/jsonrpclib/jsonrpclib-0.1.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/jsonrpclib/jsonrpclib-0.1.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/jsonrpclib/jsonrpclib-0.1.7.ebuild')
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-0.1.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/jsonrpclib/jsonrpclib-0.1.7.ebuild b/dev-python/jsonrpclib/jsonrpclib-0.1.7.ebuild
new file mode 100644
index 000000000000..d423c16be33e
--- /dev/null
+++ b/dev-python/jsonrpclib/jsonrpclib-0.1.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/joshmarshall/jsonrpclib.git"
+ inherit git-2
+else
+ SRC_URI="https://github.com/joshmarshall/jsonrpclib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~mips ~x86"
+fi
+
+DESCRIPTION="python implementation of the JSON-RPC spec (1.0 and 2.0)"
+HOMEPAGE="https://github.com/joshmarshall/jsonrpclib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/simplejson"