summaryrefslogtreecommitdiff
path: root/dev-python/jsonpointer/jsonpointer-2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-27 07:34:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-27 07:34:25 +0100
commit61faa1ea0e8302df305bc281038fc00dc7eb1dd4 (patch)
tree80638756ce07f0db3bcdc33653970fa5452df743 /dev-python/jsonpointer/jsonpointer-2.4.ebuild
parent00757bf15f0eb42661625ed16888d00af9a79561 (diff)
gentoo auto-resync : 27:06:2023 - 07:34:25
Diffstat (limited to 'dev-python/jsonpointer/jsonpointer-2.4.ebuild')
-rw-r--r--dev-python/jsonpointer/jsonpointer-2.4.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/jsonpointer/jsonpointer-2.4.ebuild b/dev-python/jsonpointer/jsonpointer-2.4.ebuild
new file mode 100644
index 000000000000..a2dc4885530d
--- /dev/null
+++ b/dev-python/jsonpointer/jsonpointer-2.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Identify specific nodes in a JSON document (according to draft 08)"
+HOMEPAGE="
+ https://github.com/stefankoegl/python-json-pointer/
+ https://pypi.org/project/jsonpointer/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}