summaryrefslogtreecommitdiff
path: root/dev-python/jsonpointer/jsonpointer-1.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/jsonpointer/jsonpointer-1.10.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/jsonpointer/jsonpointer-1.10.ebuild')
-rw-r--r--dev-python/jsonpointer/jsonpointer-1.10.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/jsonpointer/jsonpointer-1.10.ebuild b/dev-python/jsonpointer/jsonpointer-1.10.ebuild
new file mode 100644
index 000000000000..41e1a097a83a
--- /dev/null
+++ b/dev-python/jsonpointer/jsonpointer-1.10.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Identify specific nodes in a JSON document (according to draft 08)"
+HOMEPAGE="https://github.com/stefankoegl/python-json-pointer https://pypi.python.org/pypi/jsonpointer/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}