summaryrefslogtreecommitdiff
path: root/dev-python/jsonpickle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /dev-python/jsonpickle
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'dev-python/jsonpickle')
-rw-r--r--dev-python/jsonpickle/Manifest2
-rw-r--r--dev-python/jsonpickle/jsonpickle-1.2.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/jsonpickle/Manifest b/dev-python/jsonpickle/Manifest
index 72447c1e26b9..8d7e8a040a79 100644
--- a/dev-python/jsonpickle/Manifest
+++ b/dev-python/jsonpickle/Manifest
@@ -1,3 +1,5 @@
DIST jsonpickle-0.9.3.tar.gz 60489 BLAKE2B 4767809a3bd5816343e9081bdaf45cdec8dfd1e28b832675e01ae415c1ac081d0a84e2827051520999d11d0dc28a62bdd09285cf384fff0f941d3a571064e2bf SHA512 38de2ab2c15e0e28323a8cc83b0c0b0631f2f678f620e8738fee19c71492f011aa7eec428b859574a0066b9e24a08bde911a283736757964035befe3042f2e06
+DIST jsonpickle-1.2.tar.gz 74693 BLAKE2B 65f9c18b8693351995f84815d27f2d86ab65fe7a620cda0d346b88db56de45ff6aa21b7ae941e8820e16e184d9a5ac55d56caf112f3930083e63b50751fe2dd8 SHA512 0a5bfb2e77175c9174ee1783301c613e25fcfa60f07e610206d1e1e34053e90b21b12bc1b1045dd03ff2d4efe5940d85d852800037ca01397994c022f0ffb2c6
EBUILD jsonpickle-0.9.3.ebuild 1540 BLAKE2B 670224c291caa2b087cf02b055de38bccc811868196eb8e25afc8666537ca247d6a0dbd8059619f8d8cc159cedfbf155eb175e22d885270d1f7e05cbd88f3ee7 SHA512 7cdd4db2d62db30b2627f15f22081249b030b4e4364ab342970595fda2e43876a639641d5a2b5c424a742ed47cbc6039a2ffc6b0f7ea9625575334fb612d22b8
+EBUILD jsonpickle-1.2.ebuild 1532 BLAKE2B 88afbe861162bc9d29a11e9663bed964a52e9f3e477b77d4f422725cc23a53e4c1b1d1541697808d25187b42608e1193dd02d589ca1c9b160c6a8d8f203cd19f SHA512 34862322b3184f4baf1dbb86f0e029e38b7292f1e8ebccad2132dd1ba2960cf1373d6d01a8b8acf535bb6ad0c40a257ae4b77df91d4ac9acbb4b961c8434d789
MISC metadata.xml 386 BLAKE2B 486aa3823ac1ae6b816068ae775da293fedab7120df504f2bb64cbbd026e1ad4ac2041acfb48035b5816616dedd46a5f4bedf8c63daad2315727cdbaedcd15ad SHA512 12590542127c674ae6c8123b20ce5c7ed6815f9129eefb95ef3a8c064fdc25477765d397cb7d7e62772475306c0ac7389a7155655576845b936866470302b759
diff --git a/dev-python/jsonpickle/jsonpickle-1.2.ebuild b/dev-python/jsonpickle/jsonpickle-1.2.ebuild
new file mode 100644
index 000000000000..f4a6601fd81f
--- /dev/null
+++ b/dev-python/jsonpickle/jsonpickle-1.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for serializing any arbitrary object graph into JSON"
+HOMEPAGE="https://github.com/jsonpickle/jsonpickle/ https://pypi.org/project/jsonpickle/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+# There are optional json backends serializer/deserializers in addition to those selected here
+# jsonlib, yajl.
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]
+ "
+DEPEND="test? ( ${RDEPEND} )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/sphinxtogithub[${PYTHON_USEDEP}]' python2_7) )"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading during doc build
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && { python_setup python2_7 && sphinx-build -b html -c docs/source/ docs/source/ docs/source/html || die; }
+}
+
+python_test() {
+ # An apparent regression in tests
+ # https://github.com/jsonpickle/jsonpickle/issues/124
+ einfo "testsuite has optional tests for package demjson"
+ ${PYTHON} tests/runtests.py || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/source/html/. )
+ distutils-r1_python_install_all
+}