summaryrefslogtreecommitdiff
path: root/dev-python/jsonpickle/jsonpickle-3.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-02 14:56:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-02 14:56:29 +0000
commitcc2c9e975285d6fb1be1b71d18ba4cca7991b921 (patch)
tree9b90516b35ff9055066e5b8f2e4a2ce3b6a71b38 /dev-python/jsonpickle/jsonpickle-3.0.0.ebuild
parent5a1e5a6812ca9c9555657cce48fe09d2ffa44401 (diff)
gentoo auto-resync : 02:12:2022 - 14:56:29
Diffstat (limited to 'dev-python/jsonpickle/jsonpickle-3.0.0.ebuild')
-rw-r--r--dev-python/jsonpickle/jsonpickle-3.0.0.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/jsonpickle/jsonpickle-3.0.0.ebuild b/dev-python/jsonpickle/jsonpickle-3.0.0.ebuild
new file mode 100644
index 000000000000..5d5960256f90
--- /dev/null
+++ b/dev-python/jsonpickle/jsonpickle-3.0.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for serializing any arbitrary object graph into JSON"
+HOMEPAGE="
+ https://github.com/jsonpickle/jsonpickle/
+ https://pypi.org/project/jsonpickle/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e 's:--cov::' pytest.ini || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # unpackaged bson dependency
+ tests/bson_test.py
+ # broken when gmpy is installed
+ # https://github.com/jsonpickle/jsonpickle/issues/328
+ # https://github.com/jsonpickle/jsonpickle/issues/316
+ tests/ecdsa_test.py
+ )
+ epytest
+}
+
+pkg_postinst() {
+ # Unpackaged optional backends: yajl, demjson
+ optfeature "encoding numpy-based data" dev-python/numpy
+ optfeature "encoding pandas objects" dev-python/pandas
+ optfeature "fast JSON backend" dev-python/simplejson
+}