summaryrefslogtreecommitdiff
path: root/dev-python/jsonpath-ng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-15 21:27:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-15 21:27:56 +0100
commit3648761f2708fcf5662ea1b9585f594c36eefc30 (patch)
tree7b8af3caaff06cdddb5c39ec135ecc908b62a139 /dev-python/jsonpath-ng
parent4214d835b45f0047c644e43c7fa70f1bbdb2e8b3 (diff)
gentoo auto-resync : 15:08:2023 - 21:27:55
Diffstat (limited to 'dev-python/jsonpath-ng')
-rw-r--r--dev-python/jsonpath-ng/Manifest3
-rw-r--r--dev-python/jsonpath-ng/jsonpath-ng-1.5.3.ebuild38
-rw-r--r--dev-python/jsonpath-ng/metadata.xml12
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/jsonpath-ng/Manifest b/dev-python/jsonpath-ng/Manifest
new file mode 100644
index 000000000000..715ef6edd8a0
--- /dev/null
+++ b/dev-python/jsonpath-ng/Manifest
@@ -0,0 +1,3 @@
+DIST jsonpath-ng-1.5.3.tar.gz 32819 BLAKE2B 2f217638a5f4b76d0fe2bd8d0655794281d437983abe9fda96a40440bc97ba0ad13875b7cf83d06386258c43e66732b8a9d799ccaecf5034a9d01d120f403cb6 SHA512 adf501d0db74f76216476700dce342d7a92641ecb451bdce43d0c6abce59a278dc1696b959205030de256b456ae67a554ea35a5dec272f0a4fc84c4d2b76a5c1
+EBUILD jsonpath-ng-1.5.3.ebuild 765 BLAKE2B 41dc857c66814d20f1d52c9daf667d12f020f71e1e5843962f2c876c1427b45b6c4d2f2db49a4db299a32c4436168b3c7fc1420ed341a73ff6dab446e0c49633 SHA512 2008c54a0cd92e4a23479a1ab9a45ebb241e3415d617875306ece50471a2de979fa43b99e39ad59cb50a549dfb13be6d8dcbd67ee9026dd4d6e2c56d33581eed
+MISC metadata.xml 377 BLAKE2B 773ec2b58b38244bf4925bcb99751e180092bf55a4b20b937647867a696c673592bf0bef11e2835820cad1da51783bfad76bde86200f98b0f2f1c7bac491f36e SHA512 7b0f8455e40e1db69768a1d451888c04a6805b78fbf5f0d81e4adae47539acdd3b7d4e0f33a93e81261ea7d1c5cb48fbe460d4516e3a85a86f52023270744309
diff --git a/dev-python/jsonpath-ng/jsonpath-ng-1.5.3.ebuild b/dev-python/jsonpath-ng/jsonpath-ng-1.5.3.ebuild
new file mode 100644
index 000000000000..4b2123f8e663
--- /dev/null
+++ b/dev-python/jsonpath-ng/jsonpath-ng-1.5.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_11 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python JSONPath Next-Generation"
+HOMEPAGE="
+ https://github.com/h2non/jsonpath-ng
+ https://pypi.org/project/jsonpath-ng/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/oslotest[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_jsonpath_rw_ext.py::Testjsonpath_ng_ext::test_fields_value
+)
diff --git a/dev-python/jsonpath-ng/metadata.xml b/dev-python/jsonpath-ng/metadata.xml
new file mode 100644
index 000000000000..220b98b8a585
--- /dev/null
+++ b/dev-python/jsonpath-ng/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Florian Schmaus</name>
+ <email>flow@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">h2non/jsonpath-ng</remote-id>
+ <remote-id type="pypi">jsonpath-ng</remote-id>
+ </upstream>
+</pkgmetadata>