summaryrefslogtreecommitdiff
path: root/dev-python/jsonpatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/jsonpatch
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/jsonpatch')
-rw-r--r--dev-python/jsonpatch/Manifest7
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.13.ebuild28
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.15.ebuild28
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.21.ebuild27
-rw-r--r--dev-python/jsonpatch/metadata.xml20
5 files changed, 110 insertions, 0 deletions
diff --git a/dev-python/jsonpatch/Manifest b/dev-python/jsonpatch/Manifest
new file mode 100644
index 000000000000..711a22b36ea5
--- /dev/null
+++ b/dev-python/jsonpatch/Manifest
@@ -0,0 +1,7 @@
+DIST jsonpatch-1.13.tar.gz 15119 BLAKE2B 70ddb570451ac1f3d218de0f79f0a639eb922ce72084cf3bc7e89a3efedb85c6238293bf59608a51f07c33358dc0488550f982f122e89e2414ddfce26fe08c1f SHA512 23f0c92c2c8834d5e3129e9ba78ece7da2646dd60d5b0522b0f09d83e20057ef7517042e5ee8547804185d3ce23cff394c8fe78df93fad7999fae12cc5467a45
+DIST jsonpatch-1.15.tar.gz 15544 BLAKE2B 1b9facd2a88a997356aeace8ddec9011f4f3c4df812fb157cd22f1210ac2e2502e8b9e18e02ea477c869758cdfc1dd0b6b4c8d76ce59ffdd68d4db14c550b572 SHA512 c5df880764b14a2fb60bb46e319bf006644ce1472d0413cf08ad151cf386e5be9fec197fd9efe0bfc3aa22dadf4078344c11211c1e8a3d5cc3ddcb998795dc91
+DIST jsonpatch-1.21.tar.gz 15208 BLAKE2B 88af93bfd7c317319d958bc3386f9551279af2fa9631c24c49231eb67398fd80f298e26957f232c9705219d4fa7033bb62f98b5d5391f6eb9f53113a1d351876 SHA512 dc902b750241833a68612430f07007080ed56dce8a7a4bdd1c042f944cd6cfdc03f4b422cc6bed6bc3b21ea390c5a281cd08181e27d6b57fc5fb657787c1d740
+EBUILD jsonpatch-1.13.ebuild 801 BLAKE2B b1c54c4c546b20febb77cac5e6401e8fe5a2fbf7029577ca46c8e016005c9e0be358af91b2a3da7f37a3beb2369732703c0f42a917af201dff72e41abd1076e5 SHA512 06bec10c49dc7a3b09f3ffa8aea48c67d75feb63384a1a0714f334dcfbb0615504b27fc2526ff8cc65edb7462be8a5856d139693db688d6b610f2af1896225d9
+EBUILD jsonpatch-1.15.ebuild 809 BLAKE2B 2fdc567d95b0862337ad6f6edce0fcb0180cfce4a0bd3c9f638b221eaa914af293578982b5067887f9b684d12a41f93979a235c5249d24cbe1c2607cc2515dab SHA512 288a6d1297c6d286b15b152796701cc71d9bdb9e9bf518ba50a169e31b4e56dbb67dfba2d8bb212582188b3d64a60b2fef312a66c94af626857febd821ae45a7
+EBUILD jsonpatch-1.21.ebuild 798 BLAKE2B 8f23c63c1caaabb28fff1452e869b5c3ffd61a0decd1fc01e0e97e4d522ed6b7868aaeb886715a8f4bc7704fe5caeb4f5920c41a8e1d5ad6d3a2d24967166fd7 SHA512 e6fdec8e910502d08f01f935feb19898e72ebfcfb2e30cbb83f11e0fe0011aaeca9e7b00bda539bc27e22f0545a7c619f09cb05c6d2364f1731228aea501e915
+MISC metadata.xml 679 BLAKE2B ecac7a9a6da1482f0585c29ab1e7f1ea3729dc4c2b4640440b0a1a5eddbbbdc7d2c029c4318ab3645a4025b5e21d11015ec76b21f5b069d49a37bd74dcad6e1f SHA512 37946af836c2d8b521618688ffee4b33c1864751081c1f1cd86442e6eb6cf822cfd9dbc228f834fbd31ca63b1dd24927cdb680076e2bd7ead941558ac1d2e436
diff --git a/dev-python/jsonpatch/jsonpatch-1.13.ebuild b/dev-python/jsonpatch/jsonpatch-1.13.ebuild
new file mode 100644
index 000000000000..115f4a0ed516
--- /dev/null
+++ b/dev-python/jsonpatch/jsonpatch-1.13.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+RESTRICT="test"
+
+inherit distutils-r1
+
+DESCRIPTION="Apply JSON-Patches according to
+ http://tools.ietf.org/html/draft-pbryan-json-patch-04"
+HOMEPAGE="https://github.com/stefankoegl/python-json-patch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=">=dev-python/jsonpointer-1.9[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ "${PYTHON}" tests.py || die "Tests of tests.py fail with ${EPYTHON}"
+ "${PYTHON}" ext_tests.py || die "Tests of ext_tests.py fail with ${EPYTHON}"
+}
diff --git a/dev-python/jsonpatch/jsonpatch-1.15.ebuild b/dev-python/jsonpatch/jsonpatch-1.15.ebuild
new file mode 100644
index 000000000000..06dcd9751bba
--- /dev/null
+++ b/dev-python/jsonpatch/jsonpatch-1.15.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+RESTRICT="test"
+
+inherit distutils-r1
+
+DESCRIPTION="Apply JSON-Patches according to
+ http://tools.ietf.org/html/draft-pbryan-json-patch-04"
+HOMEPAGE="https://github.com/stefankoegl/python-json-patch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=">=dev-python/jsonpointer-1.9[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ "${PYTHON}" tests.py || die "Tests of tests.py fail with ${EPYTHON}"
+ "${PYTHON}" ext_tests.py || die "Tests of ext_tests.py fail with ${EPYTHON}"
+}
diff --git a/dev-python/jsonpatch/jsonpatch-1.21.ebuild b/dev-python/jsonpatch/jsonpatch-1.21.ebuild
new file mode 100644
index 000000000000..38b78c6233da
--- /dev/null
+++ b/dev-python/jsonpatch/jsonpatch-1.21.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+RESTRICT="test"
+
+inherit distutils-r1
+
+DESCRIPTION="Apply JSON-Patches like http://tools.ietf.org/html/draft-pbryan-json-patch-04"
+HOMEPAGE="https://github.com/stefankoegl/python-json-patch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=">=dev-python/jsonpointer-1.9[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ "${PYTHON}" tests.py || die "Tests of tests.py fail with ${EPYTHON}"
+ "${PYTHON}" ext_tests.py || die "Tests of ext_tests.py fail with ${EPYTHON}"
+}
diff --git a/dev-python/jsonpatch/metadata.xml b/dev-python/jsonpatch/metadata.xml
new file mode 100644
index 000000000000..90675b487db0
--- /dev/null
+++ b/dev-python/jsonpatch/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Python library to apply JSON Patches according to
+ http://tools.ietf.org/html/draft-ietf-appsawg-json-patch-08
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">jsonpatch</remote-id>
+ <remote-id type="github">stefankoegl/python-json-patch</remote-id>
+ </upstream>
+</pkgmetadata>