summaryrefslogtreecommitdiff
path: root/dev-python/json5
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-15 10:03:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-15 10:03:16 +0100
commitd57892fd8c8d84b85e73005a433f66d85da12fa3 (patch)
tree6f735debac848918a243f90ae2fa6a2fb69e77ad /dev-python/json5
parent4a7e8a04f36caa88d1996b1dcdedb196bb4beb2f (diff)
gentoo auto-resync : 15:05:2023 - 10:03:16
Diffstat (limited to 'dev-python/json5')
-rw-r--r--dev-python/json5/Manifest2
-rw-r--r--dev-python/json5/json5-0.9.14.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/json5/Manifest b/dev-python/json5/Manifest
index 59a49b5395ac..e287f8235057 100644
--- a/dev-python/json5/Manifest
+++ b/dev-python/json5/Manifest
@@ -1,3 +1,5 @@
DIST pyjson5-0.9.11.gh.tar.gz 111445 BLAKE2B 038ac1fab6e56e6dc45dc9bff1fc5e0da21c594cb0ac1f6d888f0207fddace9663b0dbd6abbfabce857cb9fcb40348002b10a6b4133e2f2ebb2081c543e1ad9c SHA512 aca3f38cd79d4bf52ceaf1b3dd27e30bf7598fa0b369216ac820f0c913797ebf542c9eaac17e562ee07006bf83c09210c799bc1b715c7b6e7689d2dcd702d414
+DIST pyjson5-0.9.14.gh.tar.gz 111681 BLAKE2B 7e341f1054da169e95885762f6f801eb9698007c735bfa7d4eb811a4e28a76265cf7215197e16a76184abc41f180ba8895b8120fb8f79bbf1e5f8b397d90c18d SHA512 586746398227d6dfd85c1f5e2cf69f6b4dce9529ffafcbf8d4be49c61196df3f466d5701873d0ab1b0c8851227db0874e1841d1daffcaf18d43efc0e8a171048
EBUILD json5-0.9.11.ebuild 576 BLAKE2B dacdf1eca70d8e7d0233f1ef9e6368791195f9aa3b0852e9225eb09a3031d9bdc7098eeaea32e2ddd821a15fd5828d28842d512d85f2746d95076171b12878d8 SHA512 248d56fdb6f6a2d38d78ae6502ca71ecc04814e8767fe65097c5ad2f1bed0a2b3d542870b6c0f56c137c5169f40b603ade72464818ee18111cc87364b3b1bbd6
+EBUILD json5-0.9.14.ebuild 611 BLAKE2B 7071c26b1e253a1a34c1647fcdc821940f80185d22131cfd466572cb2915f5b188a52eb3aac13c4546ddd35b0ed0e8bcc3f20ae8261df39bae6314a712c9d304 SHA512 5ffc6b81b7f95df6ab4982a8a37034b16c1bb7fe8aec896884f86f94dd90740a4fce4a71d04be04b0483ec3ca8586f365eeb764a547fa6c7966a273ed010c390
MISC metadata.xml 502 BLAKE2B 9dc70229a26364dfb51ae26cff9817bcf82c47391d9fe3b6a4b11b79848f786989c62d6c3cbbed9b476da82dcbbbe9e19bf738d860ed423c3c9731c646314cf8 SHA512 257bb6f3e18053e852d693bef7eaba9e40ef5fb25ef449a275a7fbedd9a4247217bcdd016f0b3a93658ada922882bacd723235b2ab46c81dfd8cb42fe933ac74
diff --git a/dev-python/json5/json5-0.9.14.ebuild b/dev-python/json5/json5-0.9.14.ebuild
new file mode 100644
index 000000000000..24c2cc9239dc
--- /dev/null
+++ b/dev-python/json5/json5-0.9.14.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=pyjson5-${PV}
+DESCRIPTION="A Python implementation of the JSON5 data format"
+HOMEPAGE="
+ https://github.com/dpranke/pyjson5/
+ https://pypi.org/project/json5/
+"
+# no tests in sdist, as of 0.9.14
+SRC_URI="
+ https://github.com/dpranke/pyjson5/archive/refs/tags/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest