summaryrefslogtreecommitdiff
path: root/dev-python/json5/json5-0.9.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-02 21:19:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-02 21:19:42 +0100
commitca45ec83b5d77af14152011046f506005a8a71aa (patch)
tree5f5316694d864e9f8ab24c0ee020c54e6e25cceb /dev-python/json5/json5-0.9.9.ebuild
parent5b49b81b5ef191481800fac695706d35262f8781 (diff)
gentoo auto-resync : 02:08:2022 - 21:19:42
Diffstat (limited to 'dev-python/json5/json5-0.9.9.ebuild')
-rw-r--r--dev-python/json5/json5-0.9.9.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/json5/json5-0.9.9.ebuild b/dev-python/json5/json5-0.9.9.ebuild
new file mode 100644
index 000000000000..0a10cb1d1bee
--- /dev/null
+++ b/dev-python/json5/json5-0.9.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=pyjson5-${PV}
+DESCRIPTION="A Python implementation of the JSON5 data format"
+HOMEPAGE="
+ https://github.com/dpranke/pyjson5/
+ https://pypi.org/project/json5/
+"
+SRC_URI="
+ https://github.com/dpranke/pyjson5/archive/refs/tags/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest