summaryrefslogtreecommitdiff
path: root/dev-python/jschema_to_python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-17 13:54:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-17 13:54:39 +0100
commitfe7238eca1d510cb096bf290978af72ba6607930 (patch)
tree564be9d3b7f3c9537d08b9b6a75fb119777c36f3 /dev-python/jschema_to_python
parent403387a1bc2a2d98e75bf1474b21ae379b88aab2 (diff)
gentoo auto-resync : 17:10:2022 - 13:54:39
Diffstat (limited to 'dev-python/jschema_to_python')
-rw-r--r--dev-python/jschema_to_python/Manifest1
-rw-r--r--dev-python/jschema_to_python/jschema_to_python-1.2.3-r1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/jschema_to_python/Manifest b/dev-python/jschema_to_python/Manifest
index b51b43fff6b2..fb44d1352de3 100644
--- a/dev-python/jschema_to_python/Manifest
+++ b/dev-python/jschema_to_python/Manifest
@@ -1,3 +1,4 @@
DIST jschema_to_python-1.2.3.tar.gz 10061 BLAKE2B e6d16ce5950cf787bc2073c5470c304f8d10bf97fdcc53f4ec2dd00f7cc5d6ec1308ef0813ef3eaf5b98a5cd018b43f3ca30abba441c5b1cb9a02783aa596f22 SHA512 e7e37612573e2f5cf96df6fe7206ecf31c83993e40877b0587df2a42ef2f2ae192e4f8442d40cdfb728c27fca880ae5bb427935fa7b0bbd9fadbb9a643c3c1f0
+EBUILD jschema_to_python-1.2.3-r1.ebuild 703 BLAKE2B 4640c10e94b0c055f2e513b967faf608cc018558288717718aed07cded500b2c0064d524f5469bb6745b71e3e5c1ae31aeda210f802f7f40ba9ac9efae03b19f SHA512 5e505cf993b2048bd28c4b8af6ead3140076eaf6f12c08bf33f2785d26439c1164e65a934165e18bd4bb2bcfde1ee73a5c71017d954e634e17bc3efb7945da52
EBUILD jschema_to_python-1.2.3.ebuild 669 BLAKE2B 0c01331254b21c9707d45bcb1bd16b36d21ddaf36c6f7b875b9773135cfca978457bc5469b98ea7a35b88555e5bed466415ea97b23a63f41c4f460de5bb7e007 SHA512 b76ba542f301b09986ad78aaa14347f6a308ee128e764dab1720ccc263367aace1448d3e0297144088f3a328bd08b0dc0ba02b27c26ae6fad56af1748a047e35
MISC metadata.xml 390 BLAKE2B a58571973b73ec3b26585f7c5cb74b154641c233c69c98994f2681b095201b65720db0a261239997ed820a0a2320c541ef4afadf37ea37cb29eb1f201c7a4973 SHA512 8daf722689f93c63525df31433a257bf2cd6b0be36e15ecf2fe71aadbbdf1d772b1be7f96b6c9d03f1db8d035c514a99ec7ed4e3e1790216b6b7755d991883c9
diff --git a/dev-python/jschema_to_python/jschema_to_python-1.2.3-r1.ebuild b/dev-python/jschema_to_python/jschema_to_python-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..d55e8935b7b8
--- /dev/null
+++ b/dev-python/jschema_to_python/jschema_to_python-1.2.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Generate source code for Python classes from a JSON schema"
+HOMEPAGE="
+ https://pypi.org/project/jschema-to-python/
+ https://github.com/microsoft/jschema-to-python/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/jsonpickle[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest