summaryrefslogtreecommitdiff
path: root/dev-python/jq/jq-1.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-07 12:00:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-07 12:00:01 +0100
commita519cf56a0e5e456006d39c06f68de5e11c2f7e9 (patch)
treeeb3511664a62de4a02ec7f25a9a3935956e288ab /dev-python/jq/jq-1.4.1.ebuild
parentd63d16d19ab9b58260753953a431d39230f2c362 (diff)
gentoo auto-resync : 07:10:2023 - 12:00:01
Diffstat (limited to 'dev-python/jq/jq-1.4.1.ebuild')
-rw-r--r--dev-python/jq/jq-1.4.1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/jq/jq-1.4.1.ebuild b/dev-python/jq/jq-1.4.1.ebuild
deleted file mode 100644
index 093658b0c385..000000000000
--- a/dev-python/jq/jq-1.4.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P="jq.py-${PV}"
-DESCRIPTION="Python bindings for jq"
-HOMEPAGE="
- https://github.com/mwilliamson/jq.py/
- https://pypi.org/project/jq/
-"
-SRC_URI="
- https://github.com/mwilliamson/jq.py/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-# cython<3: https://bugs.gentoo.org/898684
-BDEPEND="
- <dev-python/cython-3[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_compile() {
- # Cython compilation isn't part of setup.py, so do it manually
- "${EPYTHON}" -m cython -3 jq.pyx -o jq.c || die
- distutils-r1_python_compile
-}