summaryrefslogtreecommitdiff
path: root/dev-python/jinja
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/jinja
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/jinja')
-rw-r--r--dev-python/jinja/Manifest5
-rw-r--r--dev-python/jinja/jinja-2.10.ebuild72
-rw-r--r--dev-python/jinja/jinja-2.9.5.ebuild75
-rw-r--r--dev-python/jinja/metadata.xml12
4 files changed, 0 insertions, 164 deletions
diff --git a/dev-python/jinja/Manifest b/dev-python/jinja/Manifest
deleted file mode 100644
index 963a9eff290e..000000000000
--- a/dev-python/jinja/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-DIST jinja-2.10.tar.gz 267508 BLAKE2B 3872a073bd3954a079aee74fb2f23815f75559a88a8ab6d849cc9855e158d096a1ac62c219ae7f48a54d082c3073e83749c8536439248c80494e882f6a18995f SHA512 bdfd3c4d01b39827c128cbd7f6ebc0ad1434748be41c5037ba1b23156eea1d28f805ffe2a051b4e9b5b38938615c35c8876095b0bf0bed2c139cf5ea49ae2420
-DIST jinja-2.9.5.tar.gz 486763 BLAKE2B 680b8d58056b180295b52998a573da2fe86ac8b117a942e647626aef16d42c7af89a0ba7f5ab098fcdb29bd18940e316144fea1882e15d71f67bda945b4a6ab8 SHA512 15c1b79981c4d6fcbb7fa947fe0fd7e43973433c03d6549a84deec8ad70881f7fd0d3a35160bf6371361994f838da7eb478c577de2612e004679ae51bd97b121
-EBUILD jinja-2.10.ebuild 1648 BLAKE2B 08525d2201474c12ef384f743ab57c7e1ba1532087234f34ca54aee585b2dc5a6a77185659363aed3227a27b1e3943f08dcb5ae54c683a63ae2430c5ccdbf3ad SHA512 2481a9362d6b4e69db1aed1a66710e8d5e1cd66b9b3e3995f24ba866d89f600bc79d453aca5f9bd5eb125f02e82f377b3b17b1451090453fc324b87b13406c35
-EBUILD jinja-2.9.5.ebuild 1740 BLAKE2B d08759cb68d6a1b856138fd0c881c055ed54bb81d69e9e8ea478123fbe691b1e34051a4de95ba96381858f9a550ffa2c635d8f4f79ce7347bc319829bf656ba2 SHA512 94aa068503ab5f0fe4841da24888b1e8cd48b456a72c95a6f9cc61b40991801f24212ade37842366d7b4bfde7676af332c84549e2cad9fc82cc729a8ef18a97a
-MISC metadata.xml 374 BLAKE2B 7d6caffa81473cac206ff3ad29cc5be6ebc22d82bd3a7eb0befec7cd65a859aa9208851237c629d0c019307986eafda5a93d2977d62f847d68dfe5d415139daf SHA512 5c3b1f608d45786b27c3bf31f04816f6a85e2cfaa44eec5a9aa21029a2e8ab26264e87f9a6faa4c44a44d718aa8186110fb4d0878655dd76d880a7173b6e5d59
diff --git a/dev-python/jinja/jinja-2.10.ebuild b/dev-python/jinja/jinja-2.10.ebuild
deleted file mode 100644
index abf3450a5297..000000000000
--- a/dev-python/jinja/jinja-2.10.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit eutils distutils-r1
-
-DESCRIPTION="A full-featured template engine for Python"
-HOMEPAGE="http://jinja.pocoo.org/ https://pypi.org/project/Jinja2/"
-
-# pypi tarball is missing tests
-SRC_URI="https://github.com/pallets/jinja/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/markupsafe[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- !dev-python/jinja:compat"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-# XXX: handle Babel better?
-
-wrap_opts() {
- local mydistutilsargs=()
-
- if [[ ${EPYTHON} == python* ]]; then
- mydistutilargs+=( --with-debugsupport )
- fi
-
- "${@}"
-}
-
-python_compile() {
- wrap_opts distutils-r1_python_compile
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- py.test || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- if use examples ; then
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-
- insinto /usr/share/vim/vimfiles/syntax
- doins ext/Vim/*
-}
-
-pkg_postinst() {
- if ! has_version dev-python/Babel; then
- elog "For i18n support, please emerge dev-python/Babel."
- fi
-}
diff --git a/dev-python/jinja/jinja-2.9.5.ebuild b/dev-python/jinja/jinja-2.9.5.ebuild
deleted file mode 100644
index 804c1f5e493c..000000000000
--- a/dev-python/jinja/jinja-2.9.5.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit eutils distutils-r1
-
-DESCRIPTION="A full-featured template engine for Python"
-HOMEPAGE="http://jinja.pocoo.org/ https://pypi.org/project/Jinja2/"
-
-# pypi tarball is missing tests
-SRC_URI="https://github.com/pallets/jinja/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/markupsafe[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- !dev-python/jinja:compat"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-# XXX: handle Babel better?
-
-wrap_opts() {
- local mydistutilsargs=()
-
- if [[ ${EPYTHON} == python* ]]; then
- mydistutilargs+=( --with-debugsupport )
- fi
-
- "${@}"
-}
-
-python_compile() {
- wrap_opts distutils-r1_python_compile
- if [[ ${EPYTHON} == python3.2 ]]; then
- 2to3 --no-diffs -n -w -f unicode "${BUILD_DIR}/lib" || die
- fi
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- py.test || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- if use examples ; then
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-
- insinto /usr/share/vim/vimfiles/syntax
- doins ext/Vim/*
-}
-
-pkg_postinst() {
- if ! has_version dev-python/Babel; then
- elog "For i18n support, please emerge dev-python/Babel."
- fi
-}
diff --git a/dev-python/jinja/metadata.xml b/dev-python/jinja/metadata.xml
deleted file mode 100644
index 03be6412af96..000000000000
--- a/dev-python/jinja/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">Jinja2</remote-id>
- <remote-id type="github">pallets/jinja</remote-id>
- </upstream>
-</pkgmetadata>