summaryrefslogtreecommitdiff
path: root/dev-python/jc/jc-1.25.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-13 05:35:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-13 05:35:51 +0000
commit9e166f0fa8bc64fb267aaba88d9a55f8393e15a0 (patch)
tree8e5bf47e5b23c73057fb21ad97f5babca40da0cd /dev-python/jc/jc-1.25.1.ebuild
parentfd3c1be769bb61186a7d433ce694b0059a8f84a5 (diff)
gentoo auto-resync : 13:02:2024 - 05:35:50
Diffstat (limited to 'dev-python/jc/jc-1.25.1.ebuild')
-rw-r--r--dev-python/jc/jc-1.25.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/jc/jc-1.25.1.ebuild b/dev-python/jc/jc-1.25.1.ebuild
new file mode 100644
index 000000000000..3d8d793333ec
--- /dev/null
+++ b/dev-python/jc/jc-1.25.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Converts the output of popular command-line tools and file-types to JSON"
+HOMEPAGE="
+ https://github.com/kellyjonbrazil/jc/
+ https://pypi.org/project/jc/
+"
+# no tests in sdist, as of 1.23.2
+SRC_URI="
+ https://github.com/kellyjonbrazil/jc/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+RDEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest