summaryrefslogtreecommitdiff
path: root/dev-python/jc/jc-1.22.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-09 15:26:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-09 15:26:14 +0000
commit116b320513d92b6d49648834e8d5a043cd757feb (patch)
tree1eef0875165c4402e6dc1db35681158aed9786ca /dev-python/jc/jc-1.22.2.ebuild
parentfc2c8b325a27d1dd0e181a50517601b4fde8aa7f (diff)
gentoo auto-resync : 09:11:2022 - 15:26:14
Diffstat (limited to 'dev-python/jc/jc-1.22.2.ebuild')
-rw-r--r--dev-python/jc/jc-1.22.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/jc/jc-1.22.2.ebuild b/dev-python/jc/jc-1.22.2.ebuild
new file mode 100644
index 000000000000..7b7bbfc30991
--- /dev/null
+++ b/dev-python/jc/jc-1.22.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Converts the output of popular command-line tools and file-types to JSON"
+HOMEPAGE="
+ https://github.com/kellyjonbrazil/jc/
+ https://pypi.org/project/jc/
+"
+SRC_URI="
+ https://github.com/kellyjonbrazil/jc/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+RDEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest