summaryrefslogtreecommitdiff
path: root/dev-python/jc/jc-1.22.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-24 21:52:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-24 21:52:37 +0100
commit7ae4e1d32a98b596d483a19ed94a21b560eb595d (patch)
tree1c68a1258f5017984a7878d5e913d95d72544f59 /dev-python/jc/jc-1.22.1.ebuild
parent145ac95c683ecda55a9b2cafc84dced2e9c29e03 (diff)
gentoo auto-resync : 24:10:2022 - 21:52:37
Diffstat (limited to 'dev-python/jc/jc-1.22.1.ebuild')
-rw-r--r--dev-python/jc/jc-1.22.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/jc/jc-1.22.1.ebuild b/dev-python/jc/jc-1.22.1.ebuild
new file mode 100644
index 000000000000..7b7bbfc30991
--- /dev/null
+++ b/dev-python/jc/jc-1.22.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Converts the output of popular command-line tools and file-types to JSON"
+HOMEPAGE="
+ https://github.com/kellyjonbrazil/jc/
+ https://pypi.org/project/jc/
+"
+SRC_URI="
+ https://github.com/kellyjonbrazil/jc/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+RDEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest