summaryrefslogtreecommitdiff
path: root/dev-python/jc/jc-1.15.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/jc/jc-1.15.3.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/jc/jc-1.15.3.ebuild')
-rw-r--r--dev-python/jc/jc-1.15.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/jc/jc-1.15.3.ebuild b/dev-python/jc/jc-1.15.3.ebuild
new file mode 100644
index 000000000000..ffbe09408611
--- /dev/null
+++ b/dev-python/jc/jc-1.15.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Converts the output of popular command-line tools and file-types to JSON"
+HOMEPAGE="https://github.com/kellyjonbrazil/jc/tags"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -e "s|\\(^[[:space:]]*'[.[:alnum:]]\+\\)>=[^']*|\\1|" -i setup.py || die
+ distutils-r1_python_prepare_all
+}