summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-text
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-23 21:00:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-23 21:00:11 +0100
commit456fc832c996a122c45240beb68820ab3c2ada40 (patch)
tree947c249e75095705ddfd9e3dbb77e7b0b47bf915 /dev-python/jaraco-text
parent764cacf515464f89b60c94a29b3b7262479feb22 (diff)
gentoo auto-resync : 23:05:2023 - 21:00:10
Diffstat (limited to 'dev-python/jaraco-text')
-rw-r--r--dev-python/jaraco-text/Manifest2
-rw-r--r--dev-python/jaraco-text/jaraco-text-3.11.1.ebuild24
2 files changed, 21 insertions, 5 deletions
diff --git a/dev-python/jaraco-text/Manifest b/dev-python/jaraco-text/Manifest
index cfca6ae90ada..04e1201da9ec 100644
--- a/dev-python/jaraco-text/Manifest
+++ b/dev-python/jaraco-text/Manifest
@@ -1,3 +1,3 @@
DIST jaraco.text-3.11.1.tar.gz 16083 BLAKE2B f7268128209fbdc849a745595339f4dc9a097f3f4f8f0cdcb05ca3106ed5a45460126fbb2b7d9c3b01b63aa3f750175e8cd366034183b7d8804a1650fe493e4b SHA512 b4066589e9d4c9a2a82ae2b0825d34b22b93ee179d29c3666e9b978390121520afcb8fc5ffa6457022d2e8477f4cf2b76485d9896438ee46275326577609f201
-EBUILD jaraco-text-3.11.1.ebuild 1827 BLAKE2B 4491c3a12cecfa51c658d49afd1b12892b797455dce759e2a154d371910868785b7be56464637959e2e892d75b4eabc9d4fefe95972dad29ae6a17ea86f484c6 SHA512 7fa0b75ce79605f48e82ebe96060e80d70bfc5b07a16a86b95c218313815ee0cea8c28965222ed5bd91a6a6ef51ae5cbadd2d04b368dd12293f1426285afc999
+EBUILD jaraco-text-3.11.1.ebuild 2122 BLAKE2B 10480f54aa5147792899ef8ce357d6abc0abe3aef0915bace98232d221a59a6bcfa53746284896d0b864e96b8d2226cb35e3b97f6f749349fb195bc56bf9fd58 SHA512 67e9cad5764fe69fbc03a48d99a6b3f1060e5794a07434ee6c4c200c8e3868761c60dadc044feba362f918dbefd4d66bf91aa82b95c0dab7c034309ce658a97c
MISC metadata.xml 550 BLAKE2B 147f1a6d5bb65e6ca4a29de497742b1cc69da4f46111512c05518c54c8fc351c12aeb452cc12c0a70974094ddead7014f58a5a2fb546173334ce282e218b8c9f SHA512 fd3bf89a43ca3ebf4be15c1cff79ebc70085b0fa0192fc9a44e6e1e799044ab9935545d4722d3bc6a3989d2a3199432a47f64876ea5b822e8e46fc3c41acd005
diff --git a/dev-python/jaraco-text/jaraco-text-3.11.1.ebuild b/dev-python/jaraco-text/jaraco-text-3.11.1.ebuild
index bf60d9f2be40..0c97430b866e 100644
--- a/dev-python/jaraco-text/jaraco-text-3.11.1.ebuild
+++ b/dev-python/jaraco-text/jaraco-text-3.11.1.ebuild
@@ -7,7 +7,8 @@ EAPI=7
DISTUTILS_USE_PEP517=flit
PYPI_NO_NORMALIZE=1
PYPI_PN=${PN/-/.}
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+CLI_COMPAT=( python3_{10..11} pypy3 )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" python3_12 )
inherit distutils-r1 pypi
@@ -28,9 +29,11 @@ RDEPEND="
# needed only for CLI tool, make it PDEPEND to reduce pain in setuptools
# bootstrap
PDEPEND="
- dev-python/autocommand[${PYTHON_USEDEP}]
- dev-python/inflect[${PYTHON_USEDEP}]
- dev-python/more-itertools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/autocommand[${PYTHON_USEDEP}]
+ dev-python/inflect[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
"
BDEPEND="
test? (
@@ -59,6 +62,19 @@ src_configure() {
EOF
}
+python_test() {
+ local EPYTEST_IGNORE=()
+
+ if ! has "${EPYTHON/./_}" "${CLI_COMPAT[@]}"; then
+ EPYTEST_IGNORE+=(
+ jaraco/text/show-newlines.py
+ jaraco/text/strip-prefix.py
+ )
+ fi
+
+ epytest
+}
+
python_install() {
distutils-r1_python_install
# rename to workaround a bug in pkg_resources