summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-text
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-03 16:19:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-03 16:19:20 +0100
commit312456186919deebd1ea3b34b9e26b1e15ebd5b6 (patch)
tree9f41dbee43e2392f0e58ed3b9f43ce41e8d18fce /dev-python/jaraco-text
parentfe2f8d9da0555e4ed15cc203d8dd99dd60b3117e (diff)
gentoo auto-resync : 03:09:2022 - 16:19:20
Diffstat (limited to 'dev-python/jaraco-text')
-rw-r--r--dev-python/jaraco-text/Manifest2
-rw-r--r--dev-python/jaraco-text/jaraco-text-3.9.1.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/jaraco-text/Manifest b/dev-python/jaraco-text/Manifest
index b75a718ac2a8..cd7acf78a9fa 100644
--- a/dev-python/jaraco-text/Manifest
+++ b/dev-python/jaraco-text/Manifest
@@ -1,3 +1,5 @@
DIST jaraco.text-3.8.1.tar.gz 14160 BLAKE2B 3f8af8881665a8eb9876ae3c76ccaa68f3c58f402e1761956235bda2089e6c5e72f7968ce7fd9dd7b8dc31a08228a715c8c715dc5a93e4453af1b94c2253bce6 SHA512 2dfdd2b3bfef7c0a38a633b810a63a4337ce79b0c871f08beb369bea04585ef1b9e53afa7cef0b54c172ca25eed068af92215526d2f5cee232ccf7e72c914cfa
+DIST jaraco.text-3.9.1.tar.gz 14859 BLAKE2B 39fad64b85c8c1ea7b5bdac963b972b93ddb632940fe873fd0a646ca02d1e3a177742db9099cbbcd07dace1450c23a2e994c36f304a819e98e1c78907af975bd SHA512 f850125c7612342772d5a4a68076ea53a8cad6015c8bbe7e2923b034f8f601c8ff974eec0069b1bacba115d0aa43a948aea3b79f61d773464c823aac1880bbf1
EBUILD jaraco-text-3.8.1.ebuild 1625 BLAKE2B 324b0cb2b2eb18fd7d7e06151ac72a38e5cc3eb48d87e6993f1af67761dcdb047c11565a5cb494e89805d7319133f74751bf452f001eb864a76a1ea5c2bb2694 SHA512 5c6b1d37e875abd5beeeb4f562df96b68b432ab3216fa850494e00ec0f2d043cdecf0bb7f86dbace343e069a13be825f6097030d79cffd1932a1ee0fbd8dd8a6
+EBUILD jaraco-text-3.9.1.ebuild 1781 BLAKE2B ac557a25aad519a010017bcb462b1c7044b8b2eb462431dcdcc251c7dded8a349c41dd6ce651cab6432617e496e7df7b001961ef1958c6deb253c5e647699ff6 SHA512 1e7d50dfb68ef2fbc30e4853769a19989cc7e011595817af8093e1018fcb930e5a5e7752f9093143edc406bbc563b1a0daa3d867c19595c427b43c3bb272b43e
MISC metadata.xml 656 BLAKE2B 0a887f3b936ada76caabedd24bcfc8d1d53047705761370fdf5c2cbe204b4d7c8449813268e9a45b48409f713e038f5742db12029bb3974b703317e7c3eaa28c SHA512 c8dc08d4347fec9076d6c23899ccb6fadbeee43d64875d8ea727ce20c2c5429a2683d162d602b763ef740c8eeb213762b17b2c964132923a647b769e2372763c
diff --git a/dev-python/jaraco-text/jaraco-text-3.9.1.ebuild b/dev-python/jaraco-text/jaraco-text-3.9.1.ebuild
new file mode 100644
index 000000000000..a909d43c1fd4
--- /dev/null
+++ b/dev-python/jaraco-text/jaraco-text-3.9.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Text utilities used by other projects by developer jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.text/
+ https://pypi.org/project/jaraco.text/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/jaraco-context-4.1.1-r1[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-3.5.0-r1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_resources-5.4.0-r3[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+# needed only for CLI tool, make it PDEPEND to reduce pain in setuptools
+# bootstrap
+PDEPEND="
+ dev-python/autocommand[${PYTHON_USEDEP}]
+ dev-python/inflect[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${PDEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "jaraco.text"
+ version = "${PV}"
+ description = "Module for text manipulation"
+ EOF
+}
+
+python_install() {
+ distutils-r1_python_install
+ # rename to workaround a bug in pkg_resources
+ # https://bugs.gentoo.org/834522
+ mv "${D}$(python_get_sitedir)"/jaraco{_,.}text-${PV}.dist-info || die
+}