summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-test
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-01 08:21:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-01 08:21:34 +0000
commit1581db777aa413144ae9aaff70602eae670c8b93 (patch)
treeadb2d2c6f2a5f0843b82a50ceb35f9f286924c4e /dev-python/jaraco-test
parentd682a95de35077b0728025627e082b67339fa249 (diff)
gentoo auto-resync : 01:01:2023 - 08:21:34
Diffstat (limited to 'dev-python/jaraco-test')
-rw-r--r--dev-python/jaraco-test/Manifest2
-rw-r--r--dev-python/jaraco-test/jaraco-test-5.3.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/jaraco-test/Manifest b/dev-python/jaraco-test/Manifest
index 77ed02cc9638..b0c1ab02aa58 100644
--- a/dev-python/jaraco-test/Manifest
+++ b/dev-python/jaraco-test/Manifest
@@ -1,5 +1,7 @@
DIST jaraco.test-5.1.0.tar.gz 6700 BLAKE2B 69ac08ab7e1c8aeff45d25483f2bb2648ad57a5977dbff8aab844f114a15f054b782ad5b424d9baa805ab80fc7483362dc97320965ef0abe86573b1e7f40b97b SHA512 d1d93eab85068fcba94530df50da9221b7f574e58b2c4ed519c8c4dec7231aa982d588e29137418226f23e0f94bd98f47c0859cf14d7a58c1683ac8ccc24d900
DIST jaraco.test-5.2.0.tar.gz 8000 BLAKE2B 21e0714537a9966cc285eb1458f313c354226903ee3da816d7a6620676716cf9c220f82963c8b8ea7ac7a1d641f174d5c72dcca43c68c62e4f929c411aa00d62 SHA512 25cd7d5defda6941569958ce61cf41b54555d54c7dc1e115de409d6da352f8e8c09b8671adbdfdc00cf6f1c60a0d43201680c40dbeda44bdcf11a0e64cb23751
+DIST jaraco.test-5.3.0.tar.gz 8199 BLAKE2B bb44899e9d459350b7edff1a0212afada0765b250e7450c28e15da958632b33a17777d6db2b7ae9984772928003fbd368b6482889816198c971c77fd1f967bcd SHA512 31d2ea0557023c6996b786ee1b2a385ac8f22c2af66baab98c3a6b894bf1eaa7378a595d00bc46a537cc89fe87c9193733968fc8a586a58654b468b712d63728
EBUILD jaraco-test-5.1.0-r1.ebuild 814 BLAKE2B 485fa57bf60eaf93425b47fb479e2ec2a9c9408b57c8652f6a4e0fae706744a80270a7b366a640e6a0e2ea2dc391d0e5b48d2414a7ecea148d26f1570c17595d SHA512 125dd57f0fffaa8db952118c44b868f4db16d64cb93bcdc52e7356c3e96d5b15d2165adc69c22625aee32898fee93f5660618d5041239c93287771ba517bb5f3
EBUILD jaraco-test-5.2.0.ebuild 654 BLAKE2B f3c866cee8a17aa5304c6b2df1316adc54976dc69162365b41738cfe917e5cd2840d499279d46d982dd08f3e6707984a6fd944e0c387710ae27b563ea5850239 SHA512 2b3d93762d22e386db80313da7fcd5fc35262814ce9ff61b2c21cf50afefd3332daf1e756d702ef9451e3e54537362e6007526f3848c685228c318a822966370
+EBUILD jaraco-test-5.3.0.ebuild 950 BLAKE2B c9905b09ed148db41f68258d59c398df59fcfeaff860dd1e7e70628297da6cc22795b7f4d2d1e065969802a672bcb242c8d1b5be924427a2c002616bed892879 SHA512 6d71c855c4a30985d5276c10e2e7062e06bdeded8ada497dc5152ecf9fe00ca7a02d1e64b45070197ebd1e67539db86784d61b7a0f094b5a6bd893e5889d649f
MISC metadata.xml 397 BLAKE2B 24c07f0efc966e9d4445968ba639a5476a24a0885051e4eab17075ea9b7b6369fe9ed919ccdc0b51a1e667c8d327428caac2196c2a3e087d8b36176e7b4b2c81 SHA512 4fce74bc524dc018611c219b86b87b7643fe5d133309a00dd5ade217895165f85cfbe26b686c79fc4dd8b1e016b07c83c25afa1c015fc240ffa0ac75e4c17159
diff --git a/dev-python/jaraco-test/jaraco-test-5.3.0.ebuild b/dev-python/jaraco-test/jaraco-test-5.3.0.ebuild
new file mode 100644
index 000000000000..1604632bd7d4
--- /dev/null
+++ b/dev-python/jaraco-test/jaraco-test-5.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Testing support by jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.test/
+ https://pypi.org/project/jaraco.test/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86"
+
+RDEPEND="
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # while technically these tests are skipped when Internet is
+ # not available (they test whether auto-skipping works), we don't
+ # want any Internet access whenever possible
+ local EPYTEST_DESELECT=(
+ tests/test_http.py::test_needs_internet
+ )
+ epytest -m "not network"
+}