summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-test/jaraco-test-5.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-01 08:21:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-01 08:21:34 +0000
commit1581db777aa413144ae9aaff70602eae670c8b93 (patch)
treeadb2d2c6f2a5f0843b82a50ceb35f9f286924c4e /dev-python/jaraco-test/jaraco-test-5.3.0.ebuild
parentd682a95de35077b0728025627e082b67339fa249 (diff)
gentoo auto-resync : 01:01:2023 - 08:21:34
Diffstat (limited to 'dev-python/jaraco-test/jaraco-test-5.3.0.ebuild')
-rw-r--r--dev-python/jaraco-test/jaraco-test-5.3.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/jaraco-test/jaraco-test-5.3.0.ebuild b/dev-python/jaraco-test/jaraco-test-5.3.0.ebuild
new file mode 100644
index 000000000000..1604632bd7d4
--- /dev/null
+++ b/dev-python/jaraco-test/jaraco-test-5.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Testing support by jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.test/
+ https://pypi.org/project/jaraco.test/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86"
+
+RDEPEND="
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # while technically these tests are skipped when Internet is
+ # not available (they test whether auto-skipping works), we don't
+ # want any Internet access whenever possible
+ local EPYTEST_DESELECT=(
+ tests/test_http.py::test_needs_internet
+ )
+ epytest -m "not network"
+}