summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-test/jaraco-test-5.1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-14 19:44:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-14 19:44:42 +0100
commit4392d53af7ce45ccfe6eb14146479ef0e2bd790a (patch)
tree505de6d6499defff572e53779c70f5fac1118499 /dev-python/jaraco-test/jaraco-test-5.1.0-r1.ebuild
parent926f46a6d07cdbc78d625b2dfca6a3c27a95b14a (diff)
gentoo auto-resync : 14:10:2022 - 19:44:42
Diffstat (limited to 'dev-python/jaraco-test/jaraco-test-5.1.0-r1.ebuild')
-rw-r--r--dev-python/jaraco-test/jaraco-test-5.1.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/jaraco-test/jaraco-test-5.1.0-r1.ebuild b/dev-python/jaraco-test/jaraco-test-5.1.0-r1.ebuild
new file mode 100644
index 000000000000..1bfd53ff5f73
--- /dev/null
+++ b/dev-python/jaraco-test/jaraco-test-5.1.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Testing support by jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.test/
+ https://pypi.org/project/jaraco.test/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ppc x86"
+
+RDEPEND="
+ dev-python/jaraco-collections[${PYTHON_USEDEP}]
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # stray dep
+ sed -i -e '/toml/d' setup.cfg || die
+ distutils-r1_src_prepare
+}