summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-stream
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/jaraco-stream
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/jaraco-stream')
-rw-r--r--dev-python/jaraco-stream/Manifest7
-rw-r--r--dev-python/jaraco-stream/jaraco-stream-1.1.1.ebuild52
-rw-r--r--dev-python/jaraco-stream/jaraco-stream-1.1.ebuild49
-rw-r--r--dev-python/jaraco-stream/jaraco-stream-1.2.ebuild58
-rw-r--r--dev-python/jaraco-stream/metadata.xml16
5 files changed, 182 insertions, 0 deletions
diff --git a/dev-python/jaraco-stream/Manifest b/dev-python/jaraco-stream/Manifest
new file mode 100644
index 000000000000..d97eafe78a1d
--- /dev/null
+++ b/dev-python/jaraco-stream/Manifest
@@ -0,0 +1,7 @@
+DIST jaraco.stream-1.1.1.tar.gz 6115 BLAKE2B 0994abe3c9688722c76e656e87166fa60d4bf45fb22ccc826227629bffb60fe0be78bb7a5f9f00b8766b5ce26d641d4b347d6c0fc73c426b424c230cb7d625b6 SHA512 65c8d1652a0d63506cc3cadee590664e6a99e2f770d26f0cea1dce07c54ffe308e1df8619bc728ea81c5ac43c9c6731fe9f71e5d38d2674c4e0d63d635bb5112
+DIST jaraco.stream-1.1.tar.gz 4887 BLAKE2B 6942db399e3821b176e5c966647aa9337e31dbfe533cbd790b9531fb943b1e5fdb05fa350e9dabdff00817e59b434a0770de32f871176dea34042acf6e2f368a SHA512 5af385084623fbdfe86e9fb620f49b097dee164638bc99622ba557a26cda591e856f1fc4134bc7b73b8f7b61afaf2607686fe20c59c582324a65c22f39d74a13
+DIST jaraco.stream-1.2.tar.gz 7696 BLAKE2B fcc1aa8d26da17635b9ee7c68c278ae572cbe36a108cb30f5eb98c7ebfd2255aad499bed38ea044b28e820646b92e64602db0e2cdfc430169035882f7b6abe9b SHA512 47a96c1de12eb64e250c85d97429218606dc9bb212cf7b97e579763dd901ee063711c00307b7442be400856d3fd4e5994afbe1cb91a99e233541ffd7ff4024b9
+EBUILD jaraco-stream-1.1.1.ebuild 1199 BLAKE2B d17248c08f88f74324d918e3b09533b2ea094de180d7d6fcb3b35cb8b714467bd92a88c5c3ec03ca6d55b36a36a441fc89593ae10878be1ad7d4570c054accda SHA512 3cc3a43091ee01b0ed72f510378f7de528f3ad3a4a44a8b90ad8d4cef87c8e954e2c3a7338fa132b52c5e3ca196b11c8853a9a63cc849aac3ccd0649816110d7
+EBUILD jaraco-stream-1.1.ebuild 1140 BLAKE2B b94964bb40aadf4f950395b4cb8e164810fcb2601ddb9d21cc2498a92d97fdfa1cc60a6eb4776a9c87147fc3ad2249bbdeac13283baf07bdaef831e7c8b07c1c SHA512 9d67cc8e9ec8fa2b39a421f8a87ae5b0a7561d7555b00531ad6ac1fab470d9190bd104b5bac066aad8b5e1db0db53f7da13086986c5f34b83436547a522df599
+EBUILD jaraco-stream-1.2.ebuild 1410 BLAKE2B bca85957a1bf23a45c5e92942d75d1287c93e980eacd4588d45661b2456f1d0160da4a65083bd8d055490f36f69f9ec811a9eb7cc513e3ec37fe0e3c108293a5 SHA512 c9de3da424b1cc9424d8cf468b66968235c93bc16ea5bb0239d43aad330de2b39d71d78312a30e8b5b0fe3e1859f46c7db424dc222ec22602191d95991912768
+MISC metadata.xml 602 BLAKE2B 3875bfb93914028b263ef5b6f7af81ee9f3fc08f1217537363a02b12e69f273ad9344c5078ea284ed5edfee1389bace975f2745379c3b4b17db4fbeee4045494 SHA512 3a6635e6f38260c76979248878ff326451273bab021f3e85c23a0ae7e29d71daa53ccfa319c8d8457faa00c6fdf5ad3dc68e0693e951ecdd419182f1861a36c0
diff --git a/dev-python/jaraco-stream/jaraco-stream-1.1.1.ebuild b/dev-python/jaraco-stream/jaraco-stream-1.1.1.ebuild
new file mode 100644
index 000000000000..628b500250d4
--- /dev/null
+++ b/dev-python/jaraco-stream/jaraco-stream-1.1.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Routines for handling streaming data"
+HOMEPAGE="https://github.com/jaraco/jaraco.stream"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ # Skip one test which requires network access
+ PYTHONPATH=. py.test --ignore=jaraco/stream/test_gzip.py \
+ || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jaraco-stream/jaraco-stream-1.1.ebuild b/dev-python/jaraco-stream/jaraco-stream-1.1.ebuild
new file mode 100644
index 000000000000..d9f68a120781
--- /dev/null
+++ b/dev-python/jaraco-stream/jaraco-stream-1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Routines for handling streaming data"
+HOMEPAGE="https://github.com/jaraco/jaraco.stream"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ # Skip one test which requires network access
+ py.test --ignore=jaraco/stream/test_gzip.py \
+ || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jaraco-stream/jaraco-stream-1.2.ebuild b/dev-python/jaraco-stream/jaraco-stream-1.2.ebuild
new file mode 100644
index 000000000000..8aa4e6c40820
--- /dev/null
+++ b/dev-python/jaraco-stream/jaraco-stream-1.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Routines for handling streaming data"
+HOMEPAGE="https://github.com/jaraco/jaraco.stream"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/namespace-jaraco[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
+ >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ # Skip one test which requires network access
+ # Override pytest options to skip flake8
+ PYTHONPATH=. py.test --ignore=jaraco/stream/test_gzip.py \
+ --override-ini="addopts=--doctest-modules" \
+ || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}
diff --git a/dev-python/jaraco-stream/metadata.xml b/dev-python/jaraco-stream/metadata.xml
new file mode 100644
index 000000000000..b154260363e4
--- /dev/null
+++ b/dev-python/jaraco-stream/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sbraz@gentoo.org</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">jaraco.stream</remote-id>
+ <remote-id type="github">jaraco/jaraco.stream</remote-id>
+ <bugs-to>https://github.com/jaraco/jaraco.stream/issues</bugs-to>
+ </upstream>
+ <longdescription lang="en">
+ Routines for handling streaming data, including a set of generators for loading gzip data on the fly.
+ </longdescription>
+</pkgmetadata>