summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-logging
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-18 14:34:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-18 14:34:38 +0100
commit3fb6e94893672e0dfbae682e6a3418e3f1260bf2 (patch)
tree6b19e4b8d9cb929c7caba132adbd596883f582ca /dev-python/jaraco-logging
parent933ed80ab9b645de54b16eeb7410c0a54f47574f (diff)
gentoo auto-resync : 18:08:2022 - 14:34:37
Diffstat (limited to 'dev-python/jaraco-logging')
-rw-r--r--dev-python/jaraco-logging/Manifest2
-rw-r--r--dev-python/jaraco-logging/jaraco-logging-3.1.1.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/jaraco-logging/Manifest b/dev-python/jaraco-logging/Manifest
index 16a65d1d7d7a..2e99575fa3e8 100644
--- a/dev-python/jaraco-logging/Manifest
+++ b/dev-python/jaraco-logging/Manifest
@@ -1,3 +1,5 @@
DIST jaraco.logging-3.1.0.tar.gz 11801 BLAKE2B 858f0930b7e04ea6f1e3d13b3d7be1056ad9efa901857ded3759e450e151c8485feb1cb6eb91c8ebf7be53c649bc818759009394b20f606fd5551c82ce0d1e61 SHA512 ce9a9cbad6d6bb448615eac986d361f9c6ff477b1209e85433f12a49055a9e30125cd49bebcf915a08b8efe0732439a8e1d336e63f6454369b3e846a9a1383ba
+DIST jaraco.logging-3.1.1.gh.tar.gz 10804 BLAKE2B 32d978ae8e9105986926649dcccd710aea44e2b8ea2f4b41dfdb6cb6512cc8597951909c4e217d608245fb37b29ced544429b4f960d080f5a3436f454d042826 SHA512 80cca221c713b3868ac06332451c2bf31cb3c95e27b82275a8cd70533cd790b4e420a5851c0a5ba067a85aa4efa266e38e2b5792e2a0e97fde158357b16b1794
EBUILD jaraco-logging-3.1.0-r1.ebuild 880 BLAKE2B fada073312b4879907072a0d50f8a501270b2f74af659a58774035b47df604db81505c479e47077ec96ad2a8333de29aad5f264582437cc1605f83081a821cc7 SHA512 64f87d268fccc8af8568e41c86fdf1e5a6b53915e28fa1da6e47116d158d8f2e30f05ee698482cbc355ca9a45f2136e40211d393f6a621a5ef4814474cc9b7a2
+EBUILD jaraco-logging-3.1.1.ebuild 1025 BLAKE2B e995dcda723f49556c24be168960ed294278ff17bd2395730d72d0cf50546c1f9c48f52c0f229c4274f75240229fcc6d71bf5027e77a6cc8087071146e6b3445 SHA512 988df2e286a80b79aaf7c2f6c60902f408a46506caf6a58ba070e49667a0ad78b3900bed7ce8b389b747707caa7e6d0c569ea3cd61b70183e1c313461d0e998a
MISC metadata.xml 578 BLAKE2B 1d5b2ffc158ad19270346831bfad35fb36b8cdbd73d6175b0e007ab4dcc7872f09acca21897f9261669a7bb5633abbb2b19fa4018960bf094018f4e31e20f05e SHA512 387e591d4ea4dbb900d7e06f67a8cbf95d99adaa80da80620751eba04ac28ba8b0c5695ce9f7e246b3ebb03a855cc2ba86c8793acbabacb95403255fb8d03905
diff --git a/dev-python/jaraco-logging/jaraco-logging-3.1.1.ebuild b/dev-python/jaraco-logging/jaraco-logging-3.1.1.ebuild
new file mode 100644
index 000000000000..7c8eaa3c8628
--- /dev/null
+++ b/dev-python/jaraco-logging/jaraco-logging-3.1.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P="${P/-/.}"
+DESCRIPTION="Additional facilities to supplement Python's stdlib logging module"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.logging/
+ https://pypi.org/project/jaraco.logging/
+"
+SRC_URI="
+ https://github.com/jaraco/jaraco.logging/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/tempora[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ # create a pkgutil-style __init__.py in order to fix pytest's
+ # determination of package paths
+ cat > jaraco/__init__.py <<-EOF || die
+ __path__ = __import__("pkgutil").extend_path(__path__, __name__)
+ EOF
+ epytest --doctest-modules
+}