summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-logging
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-31 16:11:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-31 16:11:27 +0100
commit260722f712fe06c113e7b13ad2e924ed14aaf0c4 (patch)
treea29845500e555a40458a70b7ed2896588134df2a /dev-python/jaraco-logging
parent0fde6d7108b1ee9fc6ad186eff4978faa255db20 (diff)
gentoo auto-resync : 31:08:2023 - 16:11:26
Diffstat (limited to 'dev-python/jaraco-logging')
-rw-r--r--dev-python/jaraco-logging/Manifest2
-rw-r--r--dev-python/jaraco-logging/jaraco-logging-3.2.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/jaraco-logging/Manifest b/dev-python/jaraco-logging/Manifest
index 44bb523797c0..1ff7f63b4287 100644
--- a/dev-python/jaraco-logging/Manifest
+++ b/dev-python/jaraco-logging/Manifest
@@ -1,3 +1,5 @@
DIST jaraco.logging-3.1.2.tar.gz 8107 BLAKE2B add8236bdf345d55186d8ab7432c2b392df6921229c23c253a3b224d0362073c417cd4c0540e28117a1331adea15d4e8a17ad72c2cf7084375a19c64c529ccc0 SHA512 d6d26364e44be089616913938d200f26c9da269853d673f1518c3e29905961dda264b95e60a7051e4e0d6b873eb9b65faefa9962a48e2cad43435ca32ef0e1f3
+DIST jaraco.logging-3.2.0.tar.gz 8907 BLAKE2B 9329655842f1e46af1a8eff72d97bd8c46dea60bdf1fb1e4decf5a47a95d162b825c6586db6629529a833b36944a38c536d0bb8127c60ac04e91d9553cf49682 SHA512 dd5a66bf03d01378e542553c08f8daf6aa2ec9aa8087b8d11f34b4527a1fb1e41b20142ac9b5d9e5eb8f510f50f7d1a3ec11a8eff9871190b4d4392b68bbada7
EBUILD jaraco-logging-3.1.2.ebuild 886 BLAKE2B dd35c386983747c6127ab0aa57e9326ef697cd906e0c9a23b972e6ea0f6837aa56881a3605da64cbea14b795011f6a9fb4d2fa6ba4aa297d7fbeacb44a90a2cf SHA512 0bb25d33804e3487fd376854585adc3fd5a9f8f4f6e637fc98800d8d2f2caafdb7a6c34bbc40205fcdec2180972e9090c6811d46c18cb60ecab5b2c306902b76
+EBUILD jaraco-logging-3.2.0.ebuild 888 BLAKE2B 66f4ba6601b6bda31819475f6a993ec44efa2492f71a5a054f64fe687dd2d8ce19c0545a0c36dd1f8b545c8170ee1f48cb2e491dbb38bc3a0488a9ff8b106aef SHA512 089c0e3ee0f4ff52c1c61ce06ebddc83cbcdf7958574d9fc5a2f8a872806dc3e8423ece4c75be7f81a774d3bc385d70f602f0c776571392a64dfbc0c5630b5c8
MISC metadata.xml 472 BLAKE2B 49d730fc3b557765c39f1d0bf4c4cb2ee6fa58e2e781396c3e5aeee73f709a12be25c07732d294291104c8bae61d5fb4efdeb9a0c114291ad1bab35b54fd643e SHA512 93611fb746b34ac2f2b5652ebb1de307a94cfde723458e6b7a0a46deae0b026f01eed25946e1d0864191c576352b2d3abc37d2493b2af71e143a414afa3e1bfa
diff --git a/dev-python/jaraco-logging/jaraco-logging-3.2.0.ebuild b/dev-python/jaraco-logging/jaraco-logging-3.2.0.ebuild
new file mode 100644
index 000000000000..c772bbabb1a8
--- /dev/null
+++ b/dev-python/jaraco-logging/jaraco-logging-3.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Additional facilities to supplement Python's stdlib logging module"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.logging/
+ https://pypi.org/project/jaraco.logging/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/tempora[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # create a pkgutil-style __init__.py in order to fix pytest's
+ # determination of package paths
+ cat > jaraco/__init__.py <<-EOF || die
+ __path__ = __import__("pkgutil").extend_path(__path__, __name__)
+ EOF
+ epytest --doctest-modules
+}