summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-logging/jaraco-logging-3.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /dev-python/jaraco-logging/jaraco-logging-3.1.0.ebuild
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'dev-python/jaraco-logging/jaraco-logging-3.1.0.ebuild')
-rw-r--r--dev-python/jaraco-logging/jaraco-logging-3.1.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/jaraco-logging/jaraco-logging-3.1.0.ebuild b/dev-python/jaraco-logging/jaraco-logging-3.1.0.ebuild
index 2e8b75674ba0..9a25e08b7941 100644
--- a/dev-python/jaraco-logging/jaraco-logging-3.1.0.ebuild
+++ b/dev-python/jaraco-logging/jaraco-logging-3.1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
inherit distutils-r1
@@ -30,8 +30,8 @@ distutils_enable_tests pytest
python_test() {
# Override pytest options to skip flake8
- PYTHONPATH=. pytest -vv --override-ini="addopts=--doctest-modules" \
- || die "tests failed with ${EPYTHON}"
+ local -x PYTHONPATH=.
+ epytest --override-ini="addopts=--doctest-modules"
}
# https://wiki.gentoo.org/wiki/Project:Python/Namespace_packages#File_collisions_between_pkgutil-style_packages