summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-functools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-05 10:11:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-05 10:11:29 +0000
commit68883bef20f77c2d72dfdf20bf5f9d4a5ea5ad9c (patch)
tree5bea0b1c5edcc839425e169609eb2bb2fc6aa760 /dev-python/jaraco-functools
parentd0f8b473674427ef4f618c94d4d132a7f79578e3 (diff)
gentoo auto-resync : 05:11:2023 - 10:11:29
Diffstat (limited to 'dev-python/jaraco-functools')
-rw-r--r--dev-python/jaraco-functools/Manifest2
-rw-r--r--dev-python/jaraco-functools/jaraco-functools-4.0.0.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/jaraco-functools/Manifest b/dev-python/jaraco-functools/Manifest
index e4bf6ffd60b7..688b79767f2f 100644
--- a/dev-python/jaraco-functools/Manifest
+++ b/dev-python/jaraco-functools/Manifest
@@ -1,3 +1,5 @@
DIST jaraco.functools-3.9.0.tar.gz 17221 BLAKE2B 2476e7cc9440ac21abf4c7d4d5af5d98f7a48c6fb55ef93428936265843a0e9bd02b22e8a2a748e7844015c530bc46ad67be8447b0eddb9b7ddcc1522b53c42b SHA512 5ec081aa07e736b6cacc1f6213e3212b4828824e86033b440d4fc630b0a9cf8e67497b37a239e167e421c41852ea6c0c65a4ccd39d73cc7f1cb831f605b86f00
+DIST jaraco.functools-4.0.0.tar.gz 17779 BLAKE2B ef403411f60e956a723350c949cdbd13fa36473ce77f6b1cea4eb5eaedbd2edd4ea902b8c062d53411c7bc12dcfd3879b0f1c82a1d21c28575f0298eb03f868d SHA512 2545bf3b9c9357ae867e7a5627582e14d0bdf25bac6acc5fbbb7e86f7aa24bc33b5bca584543b4180abdde203610b9716950110253045c1fe11f8bd045283c78
EBUILD jaraco-functools-3.9.0.ebuild 1578 BLAKE2B 7fc3af268719c63982473e806d99d38ea78d8090c99a3aa34365d635bf6077e8df264e331861ea667c05f14a9162fb697501197f7eb8593a1f08273a31efcb87 SHA512 d8811f9482be9fc33f4ee68c75fefee0913888e7c68e2005683e4d4af95ec1962a00afd9b71bd3c08eef713ed36b79a54c853f62d6b7e1ad13056f1f077dcb8f
+EBUILD jaraco-functools-4.0.0.ebuild 1503 BLAKE2B f9f2d2635685bf48865245a14f8791d8e243619a0541b396093ac4bf991080024a193db8b09b08fc828d0a72632bed59bbc2af84e9c62e151bb1eb9d0336d13a SHA512 011c83d95cc87d28fef6ff4ad73afc783f25afb1679321a9ef189a7833f1dffb6337ee84afd4699126b59c703c779f84fca2f90af98642e30e2d4c359f83f3d1
MISC metadata.xml 478 BLAKE2B 94766c8efa2aa80737f8008e10f75c11238120bad2f5ec64c27a871ac488ab562c2238ce63fef48403f3d99d7f9665f76a37656e9539fa3596a59bea89412287 SHA512 698af0dd66b9b2d33f89e1ca4716de958d7d20eaa4b7c5684f3714257a1e2e63cb419aaf0a35499dc753e45cbe5879828b3ed6c0323e60bf273a2885d3f77425
diff --git a/dev-python/jaraco-functools/jaraco-functools-4.0.0.ebuild b/dev-python/jaraco-functools/jaraco-functools-4.0.0.ebuild
new file mode 100644
index 000000000000..598e289a4315
--- /dev/null
+++ b/dev-python/jaraco-functools/jaraco-functools-4.0.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Additional functions used by other projects by developer jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.functools/
+ https://pypi.org/project/jaraco.functools/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=dev-python/more-itertools-0.12.0-r1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "jaraco.functools"
+ version = "${PV}"
+ description = "Functools like those found in stdlib"
+ EOF
+}
+
+python_install() {
+ distutils-r1_python_install
+ # rename to workaround a bug in pkg_resources
+ # https://bugs.gentoo.org/834522
+ mv "${D}$(python_get_sitedir)"/jaraco{_,.}functools-${PV}.dist-info || die
+}