summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-functools/jaraco-functools-3.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-20 08:19:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-20 08:19:52 +0000
commit0e2545bd942206b16391a6d7a256a5ef3ef497e7 (patch)
tree150f1f075f8a1fcc79cfec68d157b7c4979ce405 /dev-python/jaraco-functools/jaraco-functools-3.6.0.ebuild
parent8dd17625671faf6a47abf31d4c96a1e20d764ba5 (diff)
gentoo auto-resync : 20:02:2023 - 08:19:52
Diffstat (limited to 'dev-python/jaraco-functools/jaraco-functools-3.6.0.ebuild')
-rw-r--r--dev-python/jaraco-functools/jaraco-functools-3.6.0.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/jaraco-functools/jaraco-functools-3.6.0.ebuild b/dev-python/jaraco-functools/jaraco-functools-3.6.0.ebuild
new file mode 100644
index 000000000000..092fd7201547
--- /dev/null
+++ b/dev-python/jaraco-functools/jaraco-functools-3.6.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Additional functions used by other projects by developer jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.functools/
+ https://pypi.org/project/jaraco.functools/
+"
+SRC_URI="$(pypi_sdist_url --no-normalize "${PN/-/.}")"
+S=${WORKDIR}/${P/-/.}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-python/more-itertools-0.12.0-r1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "jaraco.functools"
+ version = "${PV}"
+ description = "Functools like those found in stdlib"
+ EOF
+}
+
+python_install() {
+ distutils-r1_python_install
+ # rename to workaround a bug in pkg_resources
+ # https://bugs.gentoo.org/834522
+ mv "${D}$(python_get_sitedir)"/jaraco{_,.}functools-${PV}.dist-info || die
+}