summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-envs/jaraco-envs-2.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-24 08:38:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-24 08:38:03 +0100
commit9c572b23bc56215e9d24d375ddd293982c07dc08 (patch)
tree7db2215a276dccb1c70adc0dacf0eac994458517 /dev-python/jaraco-envs/jaraco-envs-2.6.0.ebuild
parentd498c2e6fb30b46f7db6e726a0edc1ba2b9d52b6 (diff)
gentoo auto-resync : 24:10:2023 - 08:38:03
Diffstat (limited to 'dev-python/jaraco-envs/jaraco-envs-2.6.0.ebuild')
-rw-r--r--dev-python/jaraco-envs/jaraco-envs-2.6.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/jaraco-envs/jaraco-envs-2.6.0.ebuild b/dev-python/jaraco-envs/jaraco-envs-2.6.0.ebuild
new file mode 100644
index 000000000000..5bb7be7ddf01
--- /dev/null
+++ b/dev-python/jaraco-envs/jaraco-envs-2.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Classes for orchestrating Python (virtual) environments"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.envs/
+ https://pypi.org/project/jaraco.envs/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/path[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # optional runtime dep, not used by anything in ::gentoo
+ sed -i -e '/tox/d' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest tests
+}