summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-collections
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /dev-python/jaraco-collections
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'dev-python/jaraco-collections')
-rw-r--r--dev-python/jaraco-collections/Manifest2
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-3.1.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
index 1a41e2fed596..4500b2037f4e 100644
--- a/dev-python/jaraco-collections/Manifest
+++ b/dev-python/jaraco-collections/Manifest
@@ -1,4 +1,6 @@
AUX jaraco-collections-3.0.0-pypy.patch 977 BLAKE2B 528835efbb2d7c6f60e9f49b35032649f81d5b3ae08a8dbaa6ff1e362619eb886570c14240f1660f2a8cd63f54ab4651d26a2e401c01557582fcdd9294a037fc SHA512 6bf4b43230ce7cfaa4971cf1d8bc243378284ef2381d910a9b6932f067c689ae46a3e9caec9ef696f72aaf2d0fa9f5226f79abeeba047c847926a2f588ae27f9
DIST jaraco.collections-3.0.0.tar.gz 16439 BLAKE2B ff3690d85d91da8d88945e9ab8d16d13c7d0f67a9334f706701f9b392d8cffdd9450b2d6051a92799564cfc81310e45f50368ab729a0b68c08a9c8b0ccd9627d SHA512 c6c5d28fe4b3940c81c68bf877249805db3f508d83a0071947c7a5596d3636631df91cc6e87802b0fa6cd5c8bdd1ef2f39b924471666b44d2147cb64ad1533ad
+DIST jaraco.collections-3.1.0.tar.gz 18206 BLAKE2B c420b3c65c048840f2957ebff0e69a7e2d3db515801a54d829bc2dd9f77b804066ef15766c915b764a148eaa945fc9a30576bb00a645f4c124c031b6ccc64184 SHA512 9a3e4e60cd497ee2ed4a092bd823ecffe0d20293dd9ba491fd2c4e5df2481042efa8ba52503b001e11908982608852a0588cd70b4957d0551c066be97389652c
EBUILD jaraco-collections-3.0.0-r1.ebuild 1532 BLAKE2B add04d630b8b0126853b02c3dc9e8016dea9a682f40cd6b7eaee8747f1167b62ee1315da8f075dc0b6477da3612cfb9f8f0559a39e37be1006882c240cdde582 SHA512 55e4902449b653f49c80f4e30a9955eedb6833b13436bc878859a4ea1f2d8b5632ecec805e0a7a71ddb92eeb38780f26966e7037a3194189163795db0669cbc7
+EBUILD jaraco-collections-3.1.0.ebuild 1310 BLAKE2B a625fd1a3f20e0f64992eedabf8e6924b75c25d06c49fff2d3fd3be015c2a4568164eca1aeccf739582a7b1be0d4c5e35359dddb62af11e550a2798773f015d4 SHA512 5ee20f434970ce628f65d5f05c5267dee99d8e41f221df3e0f145c7d2c08ac69812b3e1ff6292116376039883117e51eb9db43aa13c29bd8b6366599a86d1581
MISC metadata.xml 659 BLAKE2B 93e69bff80e5efb51d41b24817d5aba23bf2a6cc6c45a81bd4b0fb43ae5da538f377ebc0441b14f3fdedbda8b3a7932defa5255087fec9cdf6ac4d35f86dfd1f SHA512 1609b6fb022a1880fde31a5e9c7096e373a3c5da4f8a7b2e256241bfdaa591d4247b259a7b5dfcb6c9ee06182c3b899eec468992b50a04eb3f1e1fba43f20b20
diff --git a/dev-python/jaraco-collections/jaraco-collections-3.1.0.ebuild b/dev-python/jaraco-collections/jaraco-collections-3.1.0.ebuild
new file mode 100644
index 000000000000..57a148e6aa8a
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-3.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="https://github.com/jaraco/jaraco.collections"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/jaraco-collections-3.0.0-pypy.patch"
+)
+
+distutils_enable_sphinx docs '>=dev-python/jaraco-packaging-3.2' \
+ '>=dev-python/rst-linker-1.9'
+distutils_enable_tests pytest
+
+python_test() {
+ # Override pytest options to skip flake8
+ PYTHONPATH=. pytest -vv --override-ini="addopts=--doctest-modules" \
+ || die "tests failed with ${EPYTHON}"
+}
+
+# https://wiki.gentoo.org/wiki/Project:Python/Namespace_packages#File_collisions_between_pkgutil-style_packages
+python_install() {
+ rm "${BUILD_DIR}"/lib/jaraco/__init__.py || die
+ # note: eclass may default to --skip-build in the future
+ distutils-r1_python_install --skip-build
+}