summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-collections
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/jaraco-collections
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/jaraco-collections')
-rw-r--r--dev-python/jaraco-collections/Manifest5
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-1.5.3.ebuild59
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-1.5.ebuild58
-rw-r--r--dev-python/jaraco-collections/metadata.xml14
4 files changed, 136 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
new file mode 100644
index 000000000000..fbaf44f553ee
--- /dev/null
+++ b/dev-python/jaraco-collections/Manifest
@@ -0,0 +1,5 @@
+DIST jaraco.collections-1.5.3.tar.gz 11669 BLAKE2B 2dbcac99edf28f4544e354724f8d95c0cbcdd793b33bcf892b403e72410f3b5b72b6eae62a49f0e56991cfb19b4ad5da0e95a3327f11fe5ae885e9a0029a92be SHA512 6e1fa88b468b9d971a7a302ebfdf8b9762404c2fdc1b003eee6653704b9f385f0f2e0c84ac075bdc81f8693195781cc5532c4adb31bcabd87974624a14e287ed
+DIST jaraco.collections-1.5.tar.gz 10615 BLAKE2B 4331a1df4a1232817e5bde97ce22b019ecb50711c0f4dfd18d050233b820a51c420719ff2a0d013e60da4710a63ab34293ee15f091b86392ec0d5e36e8262880 SHA512 7e2d3849d26422d687cfeb560f8096fb099a9c7b99b3061a06f9ad7037c3805b577754f62e5d5ead3f6f89bcd7dbf574df2844aa3c28928941ea2c99d50fc161
+EBUILD jaraco-collections-1.5.3.ebuild 1421 BLAKE2B 3acbffe1c06d6cf6234c473822e5c6c510479540105cd8beb31131959c75b9872a49647c6c7c0d0d1a789b2920afe43aa1bc978a891c5bf276a6445740d5cec8 SHA512 01f366fb92ad6b83e7aca055d74e79921ffbceef6837bf6b8f57e733923652bf0d6769ff5737ef2bcd7e9b33a9ab39e60404a71ab01defe2459d61ca628dfc23
+EBUILD jaraco-collections-1.5.ebuild 1402 BLAKE2B ea6bb23d97ca077a13ef637cb68af51d165b8f8b3319fa4d35c279413793e1aa3104fbee394f35b464ff39db264e94d63966e6ef3eaff1d369f9d02baef52666 SHA512 a48e9c9a8918ce2734bf0d2ad37e9ef85353bb502a057e3f3ce63d97ef0e9871fd086c36219452788c9bbcb29e4e0c90aa4094c4cca11360bc645e81c7c30fdd
+MISC metadata.xml 558 BLAKE2B 7952de571c053dd631177bfde7fa4904e4b37fc2a7ddeb3f17fb917d69d95b0103c9498f7f1e698bbfecba8c2df86616e0c7999b19e8c2af6ec83faf97fca8d1 SHA512 cf21f33decabe788873863bb42136123eb0dbf12527e75ebba2d06c4cb9a1b2b6d8e3def46829c1471e27a5e6b5d7e681272fae9fd58eed36294f90e21a92379
diff --git a/dev-python/jaraco-collections/jaraco-collections-1.5.3.ebuild b/dev-python/jaraco-collections/jaraco-collections-1.5.3.ebuild
new file mode 100644
index 000000000000..bd576051b345
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-1.5.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="https://github.com/jaraco/jaraco.collections"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+PDEPEND="dev-python/jaraco-text[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/namespace-jaraco[${PYTHON_USEDEP}]
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ >=dev-python/six-1.7.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
+ >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${PDEPEND}
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ # Override pytest options to skip flake8
+ PYTHONPATH=. py.test --override-ini="addopts=--doctest-modules" \
+ || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}
diff --git a/dev-python/jaraco-collections/jaraco-collections-1.5.ebuild b/dev-python/jaraco-collections/jaraco-collections-1.5.ebuild
new file mode 100644
index 000000000000..708280d2b630
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-1.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="https://github.com/jaraco/jaraco.collections"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+PDEPEND="dev-python/jaraco-text[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ if use test && ! has_version "dev-python/jaraco-text"; then
+ die "Ensure dev-python/jaraco-text is installed or the" \
+ "test suite will fail"
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jaraco-collections/metadata.xml b/dev-python/jaraco-collections/metadata.xml
new file mode 100644
index 000000000000..daf35c2a6e48
--- /dev/null
+++ b/dev-python/jaraco-collections/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sbraz@gentoo.org</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">jaraco.collections</remote-id>
+ <remote-id type="github">jaraco/jaraco.collections</remote-id>
+ <bugs-to>https://github.com/jaraco/jaraco.collections/issues</bugs-to>
+ <changelog>https://github.com/jaraco/jaraco.collections/blob/master/CHANGES.rst</changelog>
+ </upstream>
+</pkgmetadata>