summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-collections/jaraco-collections-5.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-13 12:04:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-13 12:04:20 +0100
commitd993571e2ee444d08f4e9e90d493ee37338657e3 (patch)
tree5a49a1d4ceffe800051e363f64571c3b6735d2f7 /dev-python/jaraco-collections/jaraco-collections-5.0.1.ebuild
parent266d65d0cceeb55ab2cc3bf4e465d7f35502a900 (diff)
gentoo auto-resync : 13:04:2024 - 12:04:19
Diffstat (limited to 'dev-python/jaraco-collections/jaraco-collections-5.0.1.ebuild')
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-5.0.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/jaraco-collections-5.0.1.ebuild b/dev-python/jaraco-collections/jaraco-collections-5.0.1.ebuild
new file mode 100644
index 000000000000..c57882621616
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-5.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.collections/
+ https://pypi.org/project/jaraco.collections/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}