summaryrefslogtreecommitdiff
path: root/dev-python/itunespy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/itunespy
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/itunespy')
-rw-r--r--dev-python/itunespy/Manifest4
-rw-r--r--dev-python/itunespy/files/itunespy-1.6-setup.cfg-description_file.patch9
-rw-r--r--dev-python/itunespy/itunespy-1.6-r1.ebuild30
-rw-r--r--dev-python/itunespy/metadata.xml13
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/itunespy/Manifest b/dev-python/itunespy/Manifest
new file mode 100644
index 000000000000..84e2540d8afc
--- /dev/null
+++ b/dev-python/itunespy/Manifest
@@ -0,0 +1,4 @@
+AUX itunespy-1.6-setup.cfg-description_file.patch 206 BLAKE2B a2df4fa4391a17e823cb0e389adf33a6b9045da604663007d4d43c533bc992244306f30f282a0022963882f6237f332e547186ee4fef15bab68e45a70d8c1c19 SHA512 3cfc66283030f9a2caae086afaedee858cae4a322c001fd7716e7751a6e3228c8d059a0f68a15ff0f508d0f1b54e61d38c1fd3b4b5e58aa276b0b6a8a9a114d6
+DIST itunespy-1.6.tar.gz 9724 BLAKE2B c46ccfd00a3dec1772499d3299dae7c20355628176db4e660aca0b2b819b81423ac78ce55319c822c15e1c4bf0641c2fc3c4d9ba94dafad1ffdeb503be4f76f9 SHA512 d91428e23a71bdbc62e6b8126b379aa48f06a365056147cf30eb4fa6132243d35c8a8d6dc536174a53f206bf7bcb4dcebb5a3697fac0fd88cbcb38205202ad81
+EBUILD itunespy-1.6-r1.ebuild 735 BLAKE2B fff57c918202e4de83b8b291a68df703516bd7d588e3d5d9544353e2652db8cff1038e39120a4d5cf798c1484cd106b10757d1588c56b6e37dd443683bced267 SHA512 d320d16839c9e43a4a05c85f1bba5c6dd353c5e61107191fcfbce9b6a5aaeb182e7ce864d095898d7febbb5f667787699fd3cf412cd411515a9d91cef6a9c2f3
+MISC metadata.xml 409 BLAKE2B 88afe27e4e9962a63bd257732b539d187aa00d88ee0446d7b70b0d239d22229002c0f7ec5db4f9888eabff8832e5698a1813dbe66e9ab0efd1fbcc6ca9b47a18 SHA512 d90439813c6027846bed561d8f0085c5aa9f024794d5aa3b8639644a4f62720cffcc91967bcbd31309bc1d88eef9dff91e97cd089e8814402c942c301bc99941
diff --git a/dev-python/itunespy/files/itunespy-1.6-setup.cfg-description_file.patch b/dev-python/itunespy/files/itunespy-1.6-setup.cfg-description_file.patch
new file mode 100644
index 000000000000..5c65eeb354b7
--- /dev/null
+++ b/dev-python/itunespy/files/itunespy-1.6-setup.cfg-description_file.patch
@@ -0,0 +1,9 @@
+index 224a779..0f94f37 100644
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -1,2 +1,2 @@
+ [metadata]
+-description-file = README.md
+\ No newline at end of file
++description_file = README.md
+\ No newline at end of file
diff --git a/dev-python/itunespy/itunespy-1.6-r1.ebuild b/dev-python/itunespy/itunespy-1.6-r1.ebuild
new file mode 100644
index 000000000000..8992a4973c9a
--- /dev/null
+++ b/dev-python/itunespy/itunespy-1.6-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple library to fetch data from the iTunes Store API"
+HOMEPAGE="https://github.com/sleepyfran/itunespy/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sleepyfran/${PN}.git"
+else
+ SRC_URI="https://github.com/sleepyfran/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+PATCHES=( "${FILESDIR}"/${P}-setup.cfg-description_file.patch )
diff --git a/dev-python/itunespy/metadata.xml b/dev-python/itunespy/metadata.xml
new file mode 100644
index 000000000000..f449f0046a80
--- /dev/null
+++ b/dev-python/itunespy/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/sleepyfran/itunespy/issues/</bugs-to>
+ <remote-id type="github">sleepyfran/itunespy</remote-id>
+ </upstream>
+</pkgmetadata>