summaryrefslogtreecommitdiff
path: root/dev-python/itsdangerous
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/itsdangerous
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/itsdangerous')
-rw-r--r--dev-python/itsdangerous/Manifest3
-rw-r--r--dev-python/itsdangerous/itsdangerous-0.24.ebuild28
-rw-r--r--dev-python/itsdangerous/metadata.xml11
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/itsdangerous/Manifest b/dev-python/itsdangerous/Manifest
new file mode 100644
index 000000000000..1d3ac76ceaf2
--- /dev/null
+++ b/dev-python/itsdangerous/Manifest
@@ -0,0 +1,3 @@
+DIST itsdangerous-0.24.tar.gz 46541 BLAKE2B 835a459128188083ea048fa26ecfba1e01b67618838230f9cc53b93afe540a38856b48d6deb404f19564fe79390d109bc3c7eb8738e83ba828f21a33aa94b050 SHA512 2863b6e5fda178db59bd214c6d24d04422c1021bb41bf11598aba1cbc43053aff3bb1e0539940b5769de04b68c03e8bd01d728dcbfc4bd0ba05867688574a297
+EBUILD itsdangerous-0.24.ebuild 830 BLAKE2B 8b3804e3460816f34b78b404d7145978b9dbfe6c0038a5b2c3d02185ac373551a1749659ec29d124fc8adb55cabad1e2705743c8fbf7ae4e6d9872419feb1ef1 SHA512 ae4106252644ff31bf68212c46d15e26086c89f7c44cd8d675864699595a91fc22187481cfed83cbc7f2e63535932f0050205367ebcd78f21444cf9e1c297b6c
+MISC metadata.xml 325 BLAKE2B 77ff2333a1e15eb410f0c320bf5b62c19568bea653b4cda79294debf6dad02b774f914ecfb3cecbe0adb1630e36bc82727ae77ab09f2b8314fe2ccc101df6737 SHA512 ea6c9ac90af243fc0367615835740108e37ddb9547dd9f288572af097c978e11c3fb2a17398950fbf842e6d1a4fb0410a74e769ad7b0c103b2d9301497578e22
diff --git a/dev-python/itsdangerous/itsdangerous-0.24.ebuild b/dev-python/itsdangerous/itsdangerous-0.24.ebuild
new file mode 100644
index 000000000000..3ecd7a878c58
--- /dev/null
+++ b/dev-python/itsdangerous/itsdangerous-0.24.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Various helpers to pass trusted data to untrusted environments and back"
+HOMEPAGE="https://pythonhosted.org/itsdangerous/ https://pypi.org/project/itsdangerous/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+# Required for running tests.py
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ if python_is_python3; then
+ 2to3 -f unicode -nw --no-diffs tests.py
+ fi
+ "${PYTHON}" tests.py || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/itsdangerous/metadata.xml b/dev-python/itsdangerous/metadata.xml
new file mode 100644
index 000000000000..60d737336602
--- /dev/null
+++ b/dev-python/itsdangerous/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">itsdangerous</remote-id>
+ </upstream>
+</pkgmetadata>