summaryrefslogtreecommitdiff
path: root/dev-python/isort
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-14 09:29:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-14 09:29:38 +0000
commit05a3b7c2189f095dfc46fbb03d4b3e801d3dc13a (patch)
tree46ab17fba7d43e3132d97ee97ebd604dea996018 /dev-python/isort
parentc73b611d606bc14760bad8592f5bfec28c9b1079 (diff)
gentoo auto-resync : 14:12:2022 - 09:29:38
Diffstat (limited to 'dev-python/isort')
-rw-r--r--dev-python/isort/Manifest2
-rw-r--r--dev-python/isort/isort-5.11.2.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/isort/Manifest b/dev-python/isort/Manifest
index 793671cb1929..16ba434d0a2c 100644
--- a/dev-python/isort/Manifest
+++ b/dev-python/isort/Manifest
@@ -1,5 +1,7 @@
DIST isort-5.10.1.gh.tar.gz 728462 BLAKE2B 5b892b9849293e8730e6d89592bace62009a8589d185b4d3a5bafded605ccd46fd0f2986fbad5cf1d72321d030e3193a111ab7e6114c6b4a7a67696f546b3a14 SHA512 545c1844bacc1d2d9e87e60b03b30a846ee1ebbfe2a229c3e018a2e1cc6e9a04a3691f1b2e7ec8575806f2341bc1af15eb64904b4eabd786d6b9b289cea5ce2a
DIST isort-5.11.1.gh.tar.gz 731273 BLAKE2B 9044579ae53df64b78762384eba9b329017c12a1e8208382b56fa76a0d54443379b17463ff547f014d18b0bc06a9d1382b4a7e3c7a44c6a6ada1a8ed836460eb SHA512 0d891bb0b546d01a4bb5ca4f8f62683c8864b396e2c15549b5f40da4c3b630ae9100026f95c7be78aae2e3238e9d173fdb08ea9eca519631f7dea64e0643d4d1
+DIST isort-5.11.2.gh.tar.gz 731273 BLAKE2B 02e135dcf448985ea94dc8e4f077540232099c4f1d671efc34ef7ce113a636b657948c586ab176dd85fc7e431ab54dc7ee3c3fd6515a80dc317fe82809fccf6d SHA512 30d6da4096b0a19686fccafe772ccc45c46a2abf45522afad5d86f3ad9682fd0c3df17349c859d6e359542ef2aa59071613574233d84e8fd90739999582b218c
EBUILD isort-5.10.1-r2.ebuild 1722 BLAKE2B 73ec5df8d583388fe3fe3cfb8f0777d3265ac9d330e7182f88f985914f302d7759814476182da841a1149e9fe89ba8c0b2101831451e0febb89b533cfbc97683 SHA512 2ae1eeca6549dc3b130ba94304d7d8c6db5f5776e5cf903f7b394f0653b555728cc6ac9aa0e0e52cd80ec13cc77f5b9ea487416b9a89f4183d19b2e596d6bd08
EBUILD isort-5.11.1.ebuild 1599 BLAKE2B e17260daf7e364eed3857b447e9cdf8a02f2f16c7a740cc83ac0c35837f46cc1a7a703bcb781d66ead9f665be6e0aef73472e9203ba27b183dd71814ee6e67bc SHA512 960825efe293d6d85fd3a46504b13e1762a87924731b6b5347935e802383f43088414853c848cbd1ec8e214e1e2ef756acfa694443fb585d1df621cb926487e4
+EBUILD isort-5.11.2.ebuild 1599 BLAKE2B e17260daf7e364eed3857b447e9cdf8a02f2f16c7a740cc83ac0c35837f46cc1a7a703bcb781d66ead9f665be6e0aef73472e9203ba27b183dd71814ee6e67bc SHA512 960825efe293d6d85fd3a46504b13e1762a87924731b6b5347935e802383f43088414853c848cbd1ec8e214e1e2ef756acfa694443fb585d1df621cb926487e4
MISC metadata.xml 574 BLAKE2B db8aac55351f15190d9b71508268f26b12a781b3b4f0f6836a30efc954b46b71da496129a9641655db483730435b44a5c5283132521dc3cc93279c57735a1ba4 SHA512 c8116bf66155ffeb7ac8d68822559e18252210dae604b4984aa5e6a3fb7161d785cbd235dc6f656513b5bab326f6e579489245bcef9d0a5dfadc34d7477758fb
diff --git a/dev-python/isort/isort-5.11.2.ebuild b/dev-python/isort/isort-5.11.2.ebuild
new file mode 100644
index 000000000000..bd9a3933387a
--- /dev/null
+++ b/dev-python/isort/isort-5.11.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python utility/library to sort imports"
+HOMEPAGE="
+ https://github.com/PyCQA/isort/
+ https://pypi.org/project/isort/
+"
+SRC_URI="
+ https://github.com/PyCQA/isort/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/tomli[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/pylama[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unbundle tomli
+ sed -i -e 's:from ._vendored ::' isort/settings.py || die
+ rm -r isort/_vendored || die
+ # leftover toml import used to determine .toml support
+ sed -i -e 's:import toml:toml = True:' tests/unit/test_isort.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ cp -a "${BUILD_DIR}"/{install,test} || die
+ local -x PATH=${BUILD_DIR}/test/usr/bin:${PATH}
+
+ # Install necessary plugins
+ local p
+ for p in example*/; do
+ pushd "${p}" >/dev/null || die
+ distutils_pep517_install "${BUILD_DIR}"/test
+ popd >/dev/null || die
+ done
+
+ local EPYTEST_IGNORE=(
+ # Excluded from upstream's test script
+ tests/unit/test_deprecated_finders.py
+ )
+ epytest tests/unit
+}