summaryrefslogtreecommitdiff
path: root/dev-python/isort
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /dev-python/isort
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'dev-python/isort')
-rw-r--r--dev-python/isort/Manifest2
-rw-r--r--dev-python/isort/isort-5.8.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/isort/Manifest b/dev-python/isort/Manifest
index df46187cf165..9271b643a90d 100644
--- a/dev-python/isort/Manifest
+++ b/dev-python/isort/Manifest
@@ -1,3 +1,5 @@
DIST isort-5.7.0.tar.gz 169353 BLAKE2B bafd6a0ce81ed80a3c1ad53ce320361ef11bc01a78211ad13b7947aafddd4d9bb5a4fbf65ec01d4c90dce7ebd0a2e3b1c4dcad729b1e27b1dd2c5c90c802eecf SHA512 ae5ff56394f495f6bd86f7581e0f8a67264671553b344b9dc2c5ba0b37f483ae500ebba9882ff5c315b913a689901b17de2eac403e0b4240f913c9e1864bab9f
+DIST isort-5.8.0.tar.gz 167927 BLAKE2B 59b9ee4e63e231026e25833ef8bc4a782ad7b30622d1f6b61fe177fbf0f8663ca953f68cf168abb407d3cb90fe98e29540ec3a8933a5df2ca7ba3e938ba4282f SHA512 ffeee045b5328fa410673464b2ca22d9cd1ba8dd34eff9a430b93e9ce72033100e32e3373308438bcb82b8eb7deea1f2087091e111b1204e35791958ca6944c4
EBUILD isort-5.7.0.ebuild 1706 BLAKE2B 55086f0ce409bf2e4f0bfc6cb1c2271bd79c228843c91a7da9410dbfd2eecc2cedf8c18972e9ad8714f5930c0086b31be71d372d50a7aa8819bc09606436b614 SHA512 e8919533c647fdf22347d68946d03632379655129866674a2894599d5191b50d2b12f64a759db3b28d0ce2f9e071c5446ce2c9ca7bc2f4aff2f1c4e3afbdbefd
+EBUILD isort-5.8.0.ebuild 1616 BLAKE2B a26795fce1847097d753430f0adb82b4d77faa9ffd1cac8adb7bc875dc5e7aa7e65320b14a28493874677b1802da14d2aa1d56044bc6867110364c490f448877 SHA512 cf1461f8fc070513a87399d10bba3df5418f33a3c20b09b2b5288113f0482b10c4fc4b56735ec1698754604cd0f666752a2668e7ff886269dbc8a8f601ff5403
MISC metadata.xml 573 BLAKE2B 2c70619aaf4f917f377e17b73d59656d6e0254bb0aa6c4a01159bd46b5e2e24e22b8ca04ab88ad71c9d4979ea3b484f5efec05e6ce3b40093e010108ef2a80d8 SHA512 4c06a138d3d06e1f9dbf570e6c59819de182d8453c46a5dbdabcfed424501aeba89fed659d19a6e329c33c0307790ef5c1b81d2ee5d7475c102c2bd689255259
diff --git a/dev-python/isort/isort-5.8.0.ebuild b/dev-python/isort/isort-5.8.0.ebuild
new file mode 100644
index 000000000000..4fb03c0631f5
--- /dev/null
+++ b/dev-python/isort/isort-5.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A python utility/library to sort imports"
+HOMEPAGE="https://pypi.org/project/isort/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pylama[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Some tests run the "isort" command
+ distutils_install_for_testing
+
+ local skipped_tests=(
+ # Fails without -s, run it separately to avoid unnecessary output
+ tests/unit/test_importable.py
+ # Excluded from upstream's test script
+ tests/unit/test_deprecated_finders.py
+ # Require "example_isort_formatting_plugin", we're not going
+ # to add an example package just to run a few tests
+ tests/unit/test_literal.py::test_value_assignment_list
+ tests/unit/test_ticketed_features.py::test_isort_supports_formatting_plugins_issue_1353
+ tests/unit/test_ticketed_features.py::test_isort_literals_issue_1358
+ # Same here: requires "example_shared_isort_profile"
+ tests/unit/test_ticketed_features.py::test_isort_supports_shared_profiles_issue_970
+ )
+ epytest -s tests/unit/test_importable.py
+ epytest tests/unit ${skipped_tests[@]/#/--deselect }
+}