summaryrefslogtreecommitdiff
path: root/dev-python/ipywidgets/ipywidgets-8.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-08 21:59:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-08 21:59:10 +0000
commit94f15e80a2d1bf7754cad4b53208be9c319ea7d5 (patch)
treeb7b87202adaa45edbdde23c9635d88ccefd83b68 /dev-python/ipywidgets/ipywidgets-8.1.2.ebuild
parentba7a238ca9c95cb73dc1040bfe42d78dd6970126 (diff)
gentoo auto-resync : 08:02:2024 - 21:59:09
Diffstat (limited to 'dev-python/ipywidgets/ipywidgets-8.1.2.ebuild')
-rw-r--r--dev-python/ipywidgets/ipywidgets-8.1.2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/ipywidgets-8.1.2.ebuild b/dev-python/ipywidgets/ipywidgets-8.1.2.ebuild
new file mode 100644
index 000000000000..b9f7a42007fc
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-8.1.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="
+ https://ipywidgets.readthedocs.io/
+ https://github.com/jupyter-widgets/ipywidgets/
+ https://pypi.org/project/ipywidgets/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/comm-0.1.3[${PYTHON_USEDEP}]
+ >=dev-python/ipython_genutils-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-4.0.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/ipython-6.1.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # upstream hack to autoconfigure ipywidgets in jupyter
+ # we don't have jupyterlab_widgets packaged
+ sed -i -e '/jupyterlab_widgets/d' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # https://github.com/pypy/pypy/issues/4892
+ ipywidgets/widgets/tests/test_interaction.py::test_interact_noinspect
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}