summaryrefslogtreecommitdiff
path: root/dev-python/ipyparallel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-python/ipyparallel
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-python/ipyparallel')
-rw-r--r--dev-python/ipyparallel/Manifest2
-rw-r--r--dev-python/ipyparallel/ipyparallel-6.3.0-r1.ebuild34
2 files changed, 21 insertions, 15 deletions
diff --git a/dev-python/ipyparallel/Manifest b/dev-python/ipyparallel/Manifest
index 617a03aa3cc2..8056d71dfb9c 100644
--- a/dev-python/ipyparallel/Manifest
+++ b/dev-python/ipyparallel/Manifest
@@ -1,3 +1,3 @@
DIST ipyparallel-6.3.0.tar.gz 2380153 BLAKE2B b8312102e1d2b5fc963491ebe8530e2fd73e9f941f7912fbc72a8db51e7255f5cac95a853d15a57e384926ab1aff27f2a3ad13cc45130a8b612be5dc623538ab SHA512 fe621854b9cc3e5f88aeca2b06b63bb689dd2feee0da451a0a90800d8832f4b44b23bb9a15033029cc33179276f31e982a10fc7540e6d13b04f15d96c348a295
-EBUILD ipyparallel-6.3.0-r1.ebuild 1734 BLAKE2B cdba64586d6fd36c07a4c4b9f7f752ed7d84a7e485e49603dd2392f015aab95e5a718837e88286cb2cc006fcd42a9613ce341f6f61a2350a23c9507a6a603fd1 SHA512 657f6af39aabce422d5c3cad7192a33b31ced76fec9160eb989eb65d1f9c41502b4d9cacd29b1f5903c4d1f2f62a2f7a7068bea1424d889e844575b016e8c686
+EBUILD ipyparallel-6.3.0-r1.ebuild 2283 BLAKE2B cde1a44a737d1455928d6aef1dff3b0eb22264c0403350d34bcf8d50716fa9841e5a6b8cf3ee4ce687a8415a5b3d5954041d69b31e502b0a4d609015234ef4f0 SHA512 8bf8392bc81d22cb5e165ffc6fb916364541d4875126a849eb16a039e605c1a63c600e2169ffcd920b24e915737217c5725d7c2130f401ee7afd6cc9938eca6a
MISC metadata.xml 530 BLAKE2B 3b19d29a2e5531c54fc9fb6fed6757d6eeb2a8e2f5f24318cdf8f5977f766496e575f9928d9a54a94532affc246dcc75762191fe00279427ac1110ece156d85d SHA512 cbbd4517deb574adfccd11c7677f212f1b1a086f86fe76f6aae18f0cbc5e833758d9ef574e452fe217ef92fe70dc2cd83a97f46e69b341cf9463c371bb46a781
diff --git a/dev-python/ipyparallel/ipyparallel-6.3.0-r1.ebuild b/dev-python/ipyparallel/ipyparallel-6.3.0-r1.ebuild
index e630c3d48028..58d101acfb1b 100644
--- a/dev-python/ipyparallel/ipyparallel-6.3.0-r1.ebuild
+++ b/dev-python/ipyparallel/ipyparallel-6.3.0-r1.ebuild
@@ -3,10 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="threads(+)"
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
inherit distutils-r1 optfeature
DESCRIPTION="Interactive Parallel Computing with IPython"
@@ -15,9 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
+KEYWORDS="amd64 ~arm arm64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
# About tests and tornado
# Upstreams claims to work fine with tornado 5, and it's indeed possible to
@@ -40,7 +36,6 @@ BDEPEND="${RDEPEND}
test? (
dev-python/ipython[test]
dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
dev-python/testpath[${PYTHON_USEDEP}]
)
"
@@ -48,13 +43,24 @@ BDEPEND="${RDEPEND}
distutils_enable_sphinx docs/source
distutils_enable_tests pytest
-src_prepare() {
- # TODO: investigate
- sed -e 's:test_unicode:_&:' \
- -e 's:test_temp_flags:_&:' \
- -i ipyparallel/tests/test_view.py || die
-
- distutils-r1_src_prepare
+python_test() {
+ local deselect=(
+ # we don't run a mongo instance for tests
+ ipyparallel/tests/test_mongodb.py::TestMongoBackend
+ # TODO
+ ipyparallel/tests/test_util.py::test_disambiguate_ip
+ ipyparallel/tests/test_view.py::TestView::test_temp_flags
+ ipyparallel/tests/test_view.py::TestView::test_unicode_apply_arg
+ ipyparallel/tests/test_view.py::TestView::test_unicode_apply_result
+ ipyparallel/tests/test_view.py::TestView::test_unicode_execute
+ ipyparallel/tests/test_view.py::TestView::test_sync_imports_quiet
+ )
+ [[ ${EPYTHON} == python3.10 ]] && deselect+=(
+ # failing due to irrelevant warnings
+ ipyparallel/tests/test_client.py::TestClient::test_local_ip_true_doesnt_trigger_warning
+ ipyparallel/tests/test_client.py::TestClient::test_warning_on_hostname_match
+ )
+ epytest ${deselect[@]/#/--deselect }
}
pkg_postinst() {