summaryrefslogtreecommitdiff
path: root/dev-python/ipyparallel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /dev-python/ipyparallel
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'dev-python/ipyparallel')
-rw-r--r--dev-python/ipyparallel/Manifest1
-rw-r--r--dev-python/ipyparallel/ipyparallel-6.3.0.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/ipyparallel/Manifest b/dev-python/ipyparallel/Manifest
index c1c09f436859..3ce2f3dcbdbc 100644
--- a/dev-python/ipyparallel/Manifest
+++ b/dev-python/ipyparallel/Manifest
@@ -1,4 +1,3 @@
DIST ipyparallel-6.3.0.tar.gz 2380153 BLAKE2B b8312102e1d2b5fc963491ebe8530e2fd73e9f941f7912fbc72a8db51e7255f5cac95a853d15a57e384926ab1aff27f2a3ad13cc45130a8b612be5dc623538ab SHA512 fe621854b9cc3e5f88aeca2b06b63bb689dd2feee0da451a0a90800d8832f4b44b23bb9a15033029cc33179276f31e982a10fc7540e6d13b04f15d96c348a295
EBUILD ipyparallel-6.3.0-r1.ebuild 1722 BLAKE2B cffe9c3a63146edbf8903a46ac7a69c58c3770b5962789776cbc942d47fb05006c113a88b7034f64cf1cf31b022cc61d80497dcc64b0505a4caaeda15d44bb2e SHA512 ba7697ae2dfff5a51d6d31ab367d009d9f7a87313c78d35b99f67045f622df1cca4c3f219e9eb2cc8f5dbe388e7c5fc1d831eb559a1769a3dfe82957ad6d0f3d
-EBUILD ipyparallel-6.3.0.ebuild 1722 BLAKE2B efe1f2c6e47419a21154ccc07fcec02034aed5436afef6dbe1d6f4935b6f4df8a331941d663cdf867768078b7b5fc3b7789ebeb4bf46b9b484fd7e45869a1bd7 SHA512 4a90135f003b558fa11f265ad831c9f07d84415685f203a585488e78c8b7b6b1a0893ac62a6b5ae6aca734ec585f012bd7dd66741378a99659ffc08a200417cd
MISC metadata.xml 530 BLAKE2B 3b19d29a2e5531c54fc9fb6fed6757d6eeb2a8e2f5f24318cdf8f5977f766496e575f9928d9a54a94532affc246dcc75762191fe00279427ac1110ece156d85d SHA512 cbbd4517deb574adfccd11c7677f212f1b1a086f86fe76f6aae18f0cbc5e833758d9ef574e452fe217ef92fe70dc2cd83a97f46e69b341cf9463c371bb46a781
diff --git a/dev-python/ipyparallel/ipyparallel-6.3.0.ebuild b/dev-python/ipyparallel/ipyparallel-6.3.0.ebuild
deleted file mode 100644
index 181f4ec46a71..000000000000
--- a/dev-python/ipyparallel/ipyparallel-6.3.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-PYTHON_REQ_USE="threads(+)"
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Interactive Parallel Computing with IPython"
-HOMEPAGE="https://ipyparallel.readthedocs.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-# About tests and tornado
-# Upstreams claims to work fine with tornado 5, and it's indeed possible to
-# launch a cluster with tornado 5 installed, but tests definitely don't run with
-# tornado 5 installed. Upstreams CI runs with tornado 4. This is why we limit
-# ourselves to <tornado-5 when running tests.
-
-RDEPEND="
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/ipython_genutils[${PYTHON_USEDEP}]
- dev-python/jupyter_client[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
- www-servers/tornado[${PYTHON_USEDEP}]
- "
-BDEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/ipython[test]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/testpath[${PYTHON_USEDEP}]
- )
- "
-
-distutils_enable_sphinx docs/source
-distutils_enable_tests pytest
-
-src_prepare() {
- # TODO: investigate
- sed -e 's:test_unicode:_&:' \
- -e 's:test_temp_flags:_&:' \
- -i ipyparallel/tests/test_view.py || die
-
- distutils-r1_src_prepare
-}
-
-pkg_postinst() {
- optfeature "Jupyter Notebook integration" dev-python/notebook
-}