summaryrefslogtreecommitdiff
path: root/dev-python/ipykernel/ipykernel-5.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-27 12:48:57 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-27 12:48:57 +0100
commit70b82ae359a5538711e103b0e8dfb92654296644 (patch)
tree8412b84ff9ce02a22be5251052b00feefe1d5b70 /dev-python/ipykernel/ipykernel-5.1.0.ebuild
parent64e107b9b6058580ff0432107eb37cefb0b2a7d8 (diff)
gentoo resync : 27.10.2018
Diffstat (limited to 'dev-python/ipykernel/ipykernel-5.1.0.ebuild')
-rw-r--r--dev-python/ipykernel/ipykernel-5.1.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/ipykernel/ipykernel-5.1.0.ebuild b/dev-python/ipykernel/ipykernel-5.1.0.ebuild
new file mode 100644
index 000000000000..42545dde0b45
--- /dev/null
+++ b/dev-python/ipykernel/ipykernel-5.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython Kernel for Jupyter"
+HOMEPAGE="https://github.com/ipython/ipykernel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '<dev-python/ipython-6[${PYTHON_USEDEP}]' 'python2*')
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.1.0[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose_warnings_filters[${PYTHON_USEDEP}]
+ )
+"
+
+python_install() {
+ distutils-r1_python_install
+
+ # bug 628222, specify python 2 or 3.
+ sed -e "s:python:${EPYTHON%.*}:" \
+ -i "${ED}"usr/share/jupyter/kernels/${EPYTHON%.*}/kernel.json || die
+}
+
+python_test() {
+ nosetests --verbose ipykernel || die
+}