summaryrefslogtreecommitdiff
path: root/dev-python/ipy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-python/ipy
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-python/ipy')
-rw-r--r--dev-python/ipy/Manifest4
-rw-r--r--dev-python/ipy/ipy-1.01.ebuild41
-rw-r--r--dev-python/ipy/metadata.xml1
3 files changed, 45 insertions, 1 deletions
diff --git a/dev-python/ipy/Manifest b/dev-python/ipy/Manifest
index 5367318c0712..301f269e706b 100644
--- a/dev-python/ipy/Manifest
+++ b/dev-python/ipy/Manifest
@@ -1,3 +1,5 @@
DIST IPy-1.00.tar.gz 35324 BLAKE2B a0e04201a59c61e5cc8f7ce2837c83dded99d0d786406e2e341183a0903d43ed5496ae8ea05d1bee019007bfef7420be623ab3dc08cce33812f1720a59ca413d SHA512 94a8f26cad0d966fdf8d4e57284eadf4cfde88515af6f5aafc8f9597eb0758324b876039d1a121021ba1ac26be2e2ffa89a3f5803dddefdee03fdb5d65b07a81
+DIST IPy-1.01.tar.gz 33641 BLAKE2B 10d5ac5c3df00a562393ee762e9ad0f458ecf4745f894ab23e686b7112842adcbb3f25064c0010630745273fa72280ba5ef92a951d687d0f46f341acd6c041ad SHA512 f0983254523025a1819d543877d9651fb6a9e39dabd3b043488495f681b02e43b544a0121658a0430a418a1c39b360a59db1699af87a75a16a2bdc29fcb2b74c
EBUILD ipy-1.00.ebuild 1155 BLAKE2B 8e4109ba35d142f10f676513267a3fad921dd7f32b75fbb24ab7d7de860d6cdacaebf2a3ecb7783a05ac6dab3e00211b192324b1fe9b76cd2725f793f9a7498f SHA512 057f9504a19b0d4f319ad7660d77a87656768f79a53ba39e311200b89dfbfcfb66d8699bd04ec115d97dc3703f8e9aca39c749eb292ad1b166a08de56641d20c
-MISC metadata.xml 378 BLAKE2B 22a98ad93c671966a154cbc91eb6d29fd2534caded6f12574751b75e3c5289ff99a8c964145793beec687062d91cf7ded3b1cf700a943ef07ddc214b7edfab12 SHA512 c5f3834352b39b567e934f5e95ee08657b6791d0f621d8e4e6ee3f1a90d8e2e6bb390f8e70c24efe9930805695d8e48ebf9f9a5b55771b7fdd4aa4f9de3a962a
+EBUILD ipy-1.01.ebuild 1106 BLAKE2B 1cf4b913bd71a87e87fa09ef86ea68338ab9cb34d7a29472970a9c7fbe1d7136ff4ce519be604593d5e1b6ae4468fb76f02e8cf7f86fbdb07b352427c7ae4045 SHA512 081b54c3260df1845d7436fcc97ae82d871eecaa46db78f1ff482885bfb449c78e9099ac596287f5eae094301b66fc1bc3a1f79ffcc4b7ad4a3e50781e2cfbe4
+MISC metadata.xml 403 BLAKE2B 20229385e1b06c38601686268fbbf06c3f797933946b58fad8becc44166dcebe0969ec658a7a5ebc8825cb46d11ffe6c141daf4202f290b891ea1bf4ed0be531 SHA512 07d57dc63949778a70b1c6e2976943d747cf425fa35c86409d6458783f517eac17ecd2443a9bac80d599059ea9487e1c6b9f60ebd283b1978844d22ca4c20486
diff --git a/dev-python/ipy/ipy-1.01.ebuild b/dev-python/ipy/ipy-1.01.ebuild
new file mode 100644
index 000000000000..a8260ce8a9d2
--- /dev/null
+++ b/dev-python/ipy/ipy-1.01.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+MY_PN="IPy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Class and tools for handling of IPv4 and IPv6 addresses and networks"
+HOMEPAGE="https://github.com/autocracy/python-ipy/wiki https://pypi.org/project/IPy/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+python_test() {
+ # 1 test fail under pypy, persistent from 0.82a, not a regression.
+ cp -r test_doc.py README.rst test "${BUILD_DIR}" || die
+ pushd "${BUILD_DIR}" > /dev/null || die
+ "${PYTHON}" test/test_IPy.py || die "Tests fail with ${EPYTHON}"
+ "${PYTHON}" test_doc.py || die "Doctests fail with ${EPYTHON}"
+ popd > /dev/null || die
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/ipy/metadata.xml b/dev-python/ipy/metadata.xml
index 4ec74958c566..27b69f8f156b 100644
--- a/dev-python/ipy/metadata.xml
+++ b/dev-python/ipy/metadata.xml
@@ -5,6 +5,7 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">IPy</remote-id>
<remote-id type="github">autocracy/python-ipy</remote-id>