summaryrefslogtreecommitdiff
path: root/dev-python/invoke/invoke-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /dev-python/invoke/invoke-1.1.1.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'dev-python/invoke/invoke-1.1.1.ebuild')
-rw-r--r--dev-python/invoke/invoke-1.1.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/invoke/invoke-1.1.1.ebuild b/dev-python/invoke/invoke-1.1.1.ebuild
new file mode 100644
index 000000000000..ec7d500d93db
--- /dev/null
+++ b/dev-python/invoke/invoke-1.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+inherit distutils-r1
+
+DESCRIPTION="Pythonic task execution"
+HOMEPAGE="https://pypi.org/project/invoke/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock
+ >=dev-python/pytest-3.0
+ >=dev-python/pytest-relaxed-1.1.4
+ )"
+RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1.0-skip-pty-tests.patch"
+)
+
+python_test() {
+ # -s flag is important: tests fail when pytest isn't in "no capture" mode
+ # -p pytest_relaxed: this plugin has to be loaded explicitly
+ pytest -s -v -p pytest_relaxed.plugin || die "Tests failed"
+}