summaryrefslogtreecommitdiff
path: root/dev-python/installer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-python/installer
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-python/installer')
-rw-r--r--dev-python/installer/Manifest7
-rw-r--r--dev-python/installer/installer-0.4.0.ebuild47
-rw-r--r--dev-python/installer/installer-0.4.0_p20220115.ebuild55
-rw-r--r--dev-python/installer/metadata.xml13
4 files changed, 122 insertions, 0 deletions
diff --git a/dev-python/installer/Manifest b/dev-python/installer/Manifest
new file mode 100644
index 000000000000..e8aeb57acc52
--- /dev/null
+++ b/dev-python/installer/Manifest
@@ -0,0 +1,7 @@
+DIST installer-0.4.0-py2.py3-none-any.whl.zip 451433 BLAKE2B 933b7e63b3d0306213789d493d4df112df26b432d63ecd1f8f21449520c34bd2ad542aac25069043fbb535c44f988dca927625eafd0a5a20489fc3ce2bcf84a2 SHA512 cf303bb422e329a36007b361034144a232ba021d4013bb8678dc7c326544e74ec9a3b3fe8b9d3696433dbbe90d2ce4a0ae8967fb054bd5ed49321d470be729a8
+DIST installer-0.4.0.gh.tar.gz 466643 BLAKE2B 635854b3461995cda3b7afa507ca3fe35cae8210e79de0bbd46938c8f103d7840ceca8bb388c2c9533efc78150691f980c478485ee33bafe0bae6c08a6aef8c4 SHA512 13537c479bc8ead8f8b45c8e5c5182e8b1b32c2889df8015be7f517f390a9efbea6fa167e0886dfade6621a8a2d822bfd662ee0238d3d86689619ca4d5483b26
+DIST installer-0.4.0_p20220115-cli.patch 14552 BLAKE2B 6632c1472ae0a578f6c7ed0acf1bb0d89ece924626b68c0daa28d9a7d93826837adaf6b0d40f048c4f5c2986b4328ca565340137e7b7fa7f407f62ebddc70275 SHA512 f8c6369955e0bde2bff0b935c39748d02659bc6ca0341af405e2c1026cf145479ba0b908bd769cdc05f3cc920f881b894b6a5eb7ace643951e05250ec0486b80
+DIST installer-0.4.0_p20220115.gh.tar.gz 466532 BLAKE2B 6dea3f4bacb52c4983e111d420495ee157076342a823b7062c6e5b3e4d3b70e6b2e9cb024d0c7baba6f88ed70f4303ab071d1882bc9d8dd0726f82a3e406056f SHA512 fbb0d4c8642fa2cbe2fd3be2eef7044a0353f04c67ecce20aafed33a0d7877ff55872ca5ad51390ae7e02cdb7af5dbd57b662085b60d425be95da6643b061eaa
+EBUILD installer-0.4.0.ebuild 1070 BLAKE2B 90aea78130610f2b3dc25a20245c90beb999edd0b958d28bf36b4778e7b02f9bad403e8900782095b8cbd43ba70628e036f0462a2e41db8dce19c6f271cf0355 SHA512 c17af01f99bee4546af02630615eb1859f06b17ebe9583c01d9368f1f5aef14f004197dd7bd56b67d423bfecc39c0fa072f3f9c74655183fdba46085acc8e3cc
+EBUILD installer-0.4.0_p20220115.ebuild 1317 BLAKE2B 5a957f71288538ed60bf86b2e282cdcc72a89ce955d93fc6cef4ad47d354940e0cfd335df89c1cd2de5f5e8adc39431786bd3edcba3cc7d2b34000d4433269cb SHA512 3baf8fed904c2b4f3fc5481c69ab9b7e4eab310aa168e68f08147992b2ad35cc8d4220fe865c1cd250083d3032f924cce69e39bcc4c2c5a043088ea86ec389f3
+MISC metadata.xml 396 BLAKE2B fafd8a4b677ddf2aac2df9ed3142829bd39eefd12fbdfdd1608a5ed2a299c86b18993440aa9941d609af9b4d34e9166a0464c2b9a06bde9ea08a4b91537b18bc SHA512 d9a031da54c07c60a8edca8df2c9fd1d2d7767e71038b70a0ff46da99005cda63af56cd54247e7eac716cf66cfc3a768edaa62a68c87983c7b5354ee6d8303f9
diff --git a/dev-python/installer/installer-0.4.0.ebuild b/dev-python/installer/installer-0.4.0.ebuild
new file mode 100644
index 000000000000..7cc2d248db09
--- /dev/null
+++ b/dev-python/installer/installer-0.4.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A library for installing Python wheels"
+HOMEPAGE="
+ https://pypi.org/project/installer/
+ https://github.com/pradyunsg/installer/
+ https://installer.readthedocs.io/en/latest/
+"
+SRC_URI="
+ https://github.com/pradyunsg/installer/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://files.pythonhosted.org/packages/py2.py3/${PN::1}/${PN}/${P}-py2.py3-none-any.whl
+ -> ${P}-py2.py3-none-any.whl.zip
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# NB: newer git doesn't use mock anymore
+BDEPEND="
+ app-arch/unzip
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+# do not use any build system to avoid circular deps
+python_compile() { :; }
+
+python_test() {
+ local -x PYTHONPATH=src
+ epytest
+}
+
+python_install() {
+ python_domodule src/installer "${WORKDIR}"/*.dist-info
+}
diff --git a/dev-python/installer/installer-0.4.0_p20220115.ebuild b/dev-python/installer/installer-0.4.0_p20220115.ebuild
new file mode 100644
index 000000000000..c6fad5e821fa
--- /dev/null
+++ b/dev-python/installer/installer-0.4.0_p20220115.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+EGIT_COMMIT="bf68f7b045ffc08784af03cf2433548c9ee9e8ca"
+DESCRIPTION="A library for installing Python wheels"
+HOMEPAGE="
+ https://pypi.org/project/installer/
+ https://github.com/pradyunsg/installer/
+ https://installer.readthedocs.io/en/latest/
+"
+SRC_URI="
+ https://github.com/pradyunsg/installer/archive/${EGIT_COMMIT}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://files.pythonhosted.org/packages/py2.py3/${PN::1}/${PN}/${P%_p*}-py2.py3-none-any.whl
+ -> ${P%_p*}-py2.py3-none-any.whl.zip
+ https://patch-diff.githubusercontent.com/raw/pradyunsg/installer/pull/94.diff
+ -> ${P}-cli.patch
+"
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# NB: newer git doesn't use mock anymore
+BDEPEND="
+ app-arch/unzip
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${DISTDIR}"/${P}-cli.patch
+)
+
+# do not use any build system to avoid circular deps
+python_compile() { :; }
+
+python_test() {
+ local -x PYTHONPATH=src
+ epytest
+}
+
+python_install() {
+ python_domodule src/installer "${WORKDIR}"/*.dist-info
+}
diff --git a/dev-python/installer/metadata.xml b/dev-python/installer/metadata.xml
new file mode 100644
index 000000000000..090fe7139f47
--- /dev/null
+++ b/dev-python/installer/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">installer</remote-id>
+ <remote-id type="github">pradyunsg/installer</remote-id>
+ </upstream>
+</pkgmetadata>