summaryrefslogtreecommitdiff
path: root/dev-python/indexed_gzip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-08 11:32:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-08 11:32:01 +0100
commit74cd29ea4467291ea2c34971de87d6bdc21233e9 (patch)
treed7039021b01e3b7bb7d02edc26d71052836b7832 /dev-python/indexed_gzip
parentcb861ca8e611e651d4203590e0a9c3c4c2196bd4 (diff)
gentoo auto-resync : 08:04:2023 - 11:32:01
Diffstat (limited to 'dev-python/indexed_gzip')
-rw-r--r--dev-python/indexed_gzip/Manifest2
-rw-r--r--dev-python/indexed_gzip/indexed_gzip-1.7.0.ebuild58
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/indexed_gzip/Manifest b/dev-python/indexed_gzip/Manifest
index ed1f6c542f68..cc8181203351 100644
--- a/dev-python/indexed_gzip/Manifest
+++ b/dev-python/indexed_gzip/Manifest
@@ -1,5 +1,3 @@
-DIST indexed_gzip-1.7.0.tar.gz 103849 BLAKE2B b33ef1f19e47c2dc12fd6e6fcc972badf4faaecaa5571aa44c765a6fafbec8e32fe2c4254d4e62722b6e744cfa27470ce517d08025b0492e8c032663b094344e SHA512 80f82699c6b64248f0609fb34e54e3838e642040820381cc64feb70b46721b69207686f9cccd55ebfb10dfcdee5fb5c1bf6404d1cfec07eb5a97767635c5dc4e
DIST indexed_gzip-1.7.1.tar.gz 74457 BLAKE2B b22d2120adac59e64f5bcf38c831bb54ce5d6c3dd1e959eece9a454908d9ce2aa5dc10557bd63823616bedfe9d0c039a3f1c0512ef1d22a54437353c57e15158 SHA512 fa27e476f115eca1d1d3892c3480de97cb407bd489737bebc44eb28e92be91e14312cde33a67af145b44c7d93ccc706498c2cbfe6cbff5b9b091dd083cde0f7e
-EBUILD indexed_gzip-1.7.0.ebuild 1133 BLAKE2B 7226f8419acd3db7072e735a71d2503d053a639c16255437c39f9d5f61dc94c1fb79699b40330ff460a933e209395c42a064577d94c6ff0a19e8b305d8a9f1a3 SHA512 c2840995917643faecadeb18bb9cc5fb305deb527029d21f943c7f6681ad5b8641676cc6e33840a9727aa8e982aa16173e6d91f7373b22e430832a533aba546a
EBUILD indexed_gzip-1.7.1.ebuild 1040 BLAKE2B e1ed6645f43f1faf40fc55074265dcbeec16d021cf760c2ff04e25083b37b10d0de2c1eade98ef699cd123ae24c9acafcf298e8110b7920378e91b080cf85720 SHA512 f1893224ba0efbf41892adf3a50cabc8ca1d5c8c46fd283bd8d3e9e81305973a3ba0d93b9ba710cd698bc50f58eb8f592406f4a3e660827e3f90444ad639a628
MISC metadata.xml 772 BLAKE2B c5788c4748250507ff0c231613f6d143839a48c5afac0d68bb806cb3d24e9119d5d3eae3135ca991dfff5bfc5955ddb545afd6293dd4e0565591fb779b3f88ed SHA512 726c025bb40efe9d30a4c1691df9c1a011684af4b1f56cb5ef6c857ae712807c15857c13934b67586f7141fa4a3f3e548acd6adffe12f6285492e1171c21ac99
diff --git a/dev-python/indexed_gzip/indexed_gzip-1.7.0.ebuild b/dev-python/indexed_gzip/indexed_gzip-1.7.0.ebuild
deleted file mode 100644
index 859539ace845..000000000000
--- a/dev-python/indexed_gzip/indexed_gzip-1.7.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Fast random access of gzip files in Python"
-HOMEPAGE="
- https://pypi.org/project/indexed-gzip/
- https://github.com/pauldmccarthy/indexed_gzip/
-"
-SRC_URI="
- https://github.com/pauldmccarthy/indexed_gzip/archive/v${PV}.tar.gz
- -> ${P}.tar.gz
-"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- sys-libs/zlib:=
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # strip custom "clean" command that doesn't support "-a"
- # https://bugs.gentoo.org/838955
- # TODO: this can be removed once distutils-r1 stops using clean
- sed -e '/cmdclass/d' -i setup.py || die
- distutils-r1_src_prepare
-}
-
-src_compile() {
- if use test; then
- export INDEXED_GZIP_TESTING=1
- fi
- distutils-r1_src_compile
-}
-
-python_test() {
- cd "${BUILD_DIR}/install$(python_get_sitedir)/indexed_gzip/tests" || die
- epytest
-}