summaryrefslogtreecommitdiff
path: root/dev-python/importlib_resources
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /dev-python/importlib_resources
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'dev-python/importlib_resources')
-rw-r--r--dev-python/importlib_resources/Manifest3
-rw-r--r--dev-python/importlib_resources/importlib_resources-1.0.2.ebuild27
-rw-r--r--dev-python/importlib_resources/metadata.xml22
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/importlib_resources/Manifest b/dev-python/importlib_resources/Manifest
new file mode 100644
index 000000000000..2813e592c3e6
--- /dev/null
+++ b/dev-python/importlib_resources/Manifest
@@ -0,0 +1,3 @@
+DIST importlib_resources-1.0.2.tar.gz 23605 BLAKE2B 813f913a779115575f3cab6f5be8f9e7ea706a6f0e47bc0bb29439901515b435c33975f6b1fd96d74140e488b0bd98aca3331e0d69940153b348891fd5f4f400 SHA512 3b7b254abdf2cb8ee0abf1608123c49de05d1eada081567a0e083d1f496f37643b81e771490b414dcf56672a7e7ea9aa6dd6b77ea8206d3a97e81ad69da7e927
+EBUILD importlib_resources-1.0.2.ebuild 573 BLAKE2B 9c8bc90c48618c297a23b686a0be60c4bbf4511831c67e7d62e172350baad85fbad75ccbcc482c422479accbf6fa78f3c3b89874810a3265db701c00f945d6ec SHA512 1bb242265d0edf1c10d75114e1586cb7800dff63b2d242664111bf3d138dceb9b5165fa211ff79c284f13b894298353285614dd28680e561f7da56692fefd15f
+MISC metadata.xml 778 BLAKE2B 36b7d03e0d72ed317bc10345d02b1ebb1386920178d662b7620f11917170f864e977a1b200630621bf178438384ca4598c562c9c4b7f07542cd5646a5285ad51 SHA512 f9b46228027302f61f527e6c8638150573cab5ead0d2942ec2d32b8cb9712e45a14e6157b0f8f1daee0e3f8e097e5abfd9b5f2bca948abc46a6863d785a85dc9
diff --git a/dev-python/importlib_resources/importlib_resources-1.0.2.ebuild b/dev-python/importlib_resources/importlib_resources-1.0.2.ebuild
new file mode 100644
index 000000000000..830ec759d0b0
--- /dev/null
+++ b/dev-python/importlib_resources/importlib_resources-1.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read resources from Python packages"
+HOMEPAGE="https://importlib-resources.readthedocs.io/en/latest/"
+SRC_URI="https://gitlab.com/python-devs/${PN}/-/archive/${PV}/${P}.tar.gz"
+LICENSE="Apache-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]"
+
+RDEPEND="${DEPEND}"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/importlib_resources/metadata.xml b/dev-python/importlib_resources/metadata.xml
new file mode 100644
index 000000000000..af87c20668a9
--- /dev/null
+++ b/dev-python/importlib_resources/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@seichter.de</email>
+ <name>Ralph Seichter</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Backport of Python 3.7’s standard library importlib.resources
+ module for Python 2.7, and 3.4 through 3.6. Users of Python
+ 3.7 and beyond are encouraged to use the standard library
+ module, and in fact for these versions, importlib_resources
+ just shadows that module.
+ </longdescription>
+ <upstream>
+ <remote-id type="gitlab">python-devs/importlib_resources</remote-id>
+ </upstream>
+</pkgmetadata>