summaryrefslogtreecommitdiff
path: root/dev-python/importlib_resources
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/importlib_resources
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/importlib_resources')
-rw-r--r--dev-python/importlib_resources/Manifest2
-rw-r--r--dev-python/importlib_resources/importlib_resources-5.4.0-r3.ebuild (renamed from dev-python/importlib_resources/importlib_resources-5.4.0-r2.ebuild)27
2 files changed, 22 insertions, 7 deletions
diff --git a/dev-python/importlib_resources/Manifest b/dev-python/importlib_resources/Manifest
index 64cca19ad633..07d72d62f596 100644
--- a/dev-python/importlib_resources/Manifest
+++ b/dev-python/importlib_resources/Manifest
@@ -1,3 +1,3 @@
DIST importlib_resources-5.4.0.tar.gz 30554 BLAKE2B f5be47cb63813aea15f65d251115cf398f695041871fdf6e8885fee11d9a9d7a2fbfd07efd494bd7c91077f99ab871e06d45f49de9f7e501a1691601206bfb55 SHA512 9262c185bdf79fad0a11caabc5c5df836702a74e140a9f60ace857e3f6a60fdb091639b2fb7129b17bad5a46968f43dda7d176fe39af495370dd31f04891fb1b
-EBUILD importlib_resources-5.4.0-r2.ebuild 826 BLAKE2B fcdcef7dfcb647f76f03cd5d82477b2791fd7f11e19f389f2be6ade71597890a6fcb49a5e22bc8fdf9c83f5af15d20ccd37a7c9bc6a5e21a0fe13a5b06114c75 SHA512 bcbbe52afb20f2970517d0a6d4186bae4f460d163a7d6f3c901d2c2c740063e021bb5516a225a5ffc805de3b0d61d57f5c26e383c2455c7758e61b52a4ace311
+EBUILD importlib_resources-5.4.0-r3.ebuild 1263 BLAKE2B cc9fe735356485a558359d02179da0933cd0b1eb29e9b8c673cdb0414dddcfc4869e870b3e2e4ab9dad5a481b4340df8ee1ea0b637ceb4df2bd6cdaea7ddf437 SHA512 b466aa4cee49a552bd65e85b5add38a41648a7fc0df3c31b18b20a70644df0e5653dde765c80bab379f5e99b7f8f713c902ab6f0d3b2ef98c7a854b43854887d
MISC metadata.xml 945 BLAKE2B 130dc56a13a8416168baf91e804e1fdef0d65978641c3fca5eb663b8accb5b1adc066bc4033751f03a9c729e27d0448925a7b623431922056fb7d282db052734 SHA512 ccb23df48a89f69133469722fb37acf516127b207b946cdea240cf82e2ba5422ee4e2166d1a9419031408a7624a52256e322fe7e478a9a7b8214ab4bc5c9b92b
diff --git a/dev-python/importlib_resources/importlib_resources-5.4.0-r2.ebuild b/dev-python/importlib_resources/importlib_resources-5.4.0-r3.ebuild
index 219174377b5b..9852a5a01ffc 100644
--- a/dev-python/importlib_resources/importlib_resources-5.4.0-r2.ebuild
+++ b/dev-python/importlib_resources/importlib_resources-5.4.0-r3.ebuild
@@ -1,10 +1,13 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=8
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+DISTUTILS_USE_PEP517=flit
# This is a backport of Python 3.9's importlib.resources
PYTHON_COMPAT=( pypy3 python3_8 )
+
inherit distutils-r1
DESCRIPTION="Read resources from Python packages"
@@ -17,12 +20,24 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 s
RDEPEND="
$(python_gen_cond_dep '
- dev-python/zipp[${PYTHON_USEDEP}]
+ >=dev-python/zipp-3.7.0-r1[${PYTHON_USEDEP}]
' python3_{8,9} pypy3)"
-BDEPEND="
- dev-python/toml[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-3.4.1[${PYTHON_USEDEP}]
-"
distutils_enable_tests unittest
distutils_enable_sphinx docs dev-python/rst-linker dev-python/jaraco-packaging
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "importlib_resources"
+ version = "${PV}"
+ description = "Read resources from Python packages"
+ EOF
+}