summaryrefslogtreecommitdiff
path: root/dev-python/importlib_resources
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-07-04 14:05:23 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-07-04 14:05:23 +0100
commit05b8b0e0af1d72e51a3ee61522941bf7605cd01c (patch)
tree43b0410e62aba677b4b256bc3ffe3fd333d28dbe /dev-python/importlib_resources
parent90c88731bd036e5698b281fbc0a5f3aa4c9983ac (diff)
gentoo resync : 04.07.2020
Diffstat (limited to 'dev-python/importlib_resources')
-rw-r--r--dev-python/importlib_resources/Manifest2
-rw-r--r--dev-python/importlib_resources/importlib_resources-3.0.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/importlib_resources/Manifest b/dev-python/importlib_resources/Manifest
index 7662fc51ba3f..296fd31751b5 100644
--- a/dev-python/importlib_resources/Manifest
+++ b/dev-python/importlib_resources/Manifest
@@ -1,5 +1,7 @@
DIST importlib_resources-1.5.0.tar.gz 23660 BLAKE2B aed7a2d730f945505083812355a63d3a88e07b057cf46394f3475135143e535e33dc3ebded24d233797020c805dc35decf5c5ce53758798b093f03f2951daa87 SHA512 34d14c1ff3121cc6f9ef1d3d4417831e3476e9facfcc9b35152c28a59a2c75d7723f171f4b48852f79ec46cbf54b066580745744bc54d349e2bfe12a353a9aed
DIST importlib_resources-2.0.1.tar.gz 26060 BLAKE2B 739cd7fd90cc12b5b586eb1bf3386b85cde2399e80cfe05cae5173ba5177fb1d15f7e44e7f78473ef03e37d563861f57b7c470782d1aab161eae4c40d530ca29 SHA512 7f62c5bb5650dd2689a41ddef2e9131f01d5edc99b284a7a4257fce18190f2e78c38a2c260d6fe5e6db122666435e079c417bd9011e68e35724932854c90a1bd
+DIST importlib_resources-3.0.0.tar.gz 26725 BLAKE2B e2517b0d1e576ce949ac05230892acbad59c09fa4b84401b3c957e83f40b50d12bc02360b135fe949d12c43f8f557006824e4e4a3e9ff2ce879c03362569a00c SHA512 cd29e268cacef3729024af6cae8394ce5aa8c1d8a28397fd8f009c7eaa908ed3775508bde86c26b0d233c25261b8509abb1e16c378c7c8a9bb0906224f3fdd54
EBUILD importlib_resources-1.5.0-r1.ebuild 1280 BLAKE2B 16db4dff815fc1e5dd034965e42a9d22f0f7413281856c80aa7652003799c2cdb928a8a6143a5d1d3d31b7f1dddb7ae933afe3bcf30a6d838ddaa290593b5cac SHA512 3c4c2aead9af6c6f44acde1b976bd8a853993ef1813cadff7986d41f4b627f697817e65d0ec2bdee8d6fcf3b618c3b320a3b179d8df9c4445dcc1c31d21aa837
EBUILD importlib_resources-2.0.1.ebuild 1289 BLAKE2B 199f43187b4b4dcbe438fd6d1d59dbef10712cfa389cccb3285e1589c82bfab2acc1ab2f48e0436c6e2b577a55a55287cbc6d1f0141ae166c9594756c0ce2f53 SHA512 c917897a69f256365a8ff767b810c5383ed023853d1ca914483c301729a403071efeac1e3918af71fd927ac58caf8426f7ea443cb4fd9912cef5dbc9bfd44d22
+EBUILD importlib_resources-3.0.0.ebuild 1234 BLAKE2B d325377754849aab1bd76d110ac0f86732f4c4f26096177d4c316132059353b7265b786da544a36749997d467bcb8d6a38d3f2132b3ce673998b13a615e88dd8 SHA512 7a65cc6900998459b7024c9644552043b6bf8e6644bce0919740281e632fb47be2f7822a4b5f5bf20dac2e2a72cffd7b464edf713fc3c743c47b545aa4a85662
MISC metadata.xml 895 BLAKE2B fadc4adcee6471eb31d5a1b406c9a6a29e366a50abcee105a08456b432e9a42352afdf7d08f37c3ee6100f1f57080bce2a32770b3fda96bedebfa7958957975f SHA512 6802c03cfc8049146dbbef1ff6462cb2eb01f18048a857ff0050af8e15367bff8e40521c989fcdc68c95b2025d2b7af09015f99c279ee504d556165687d7fa36
diff --git a/dev-python/importlib_resources/importlib_resources-3.0.0.ebuild b/dev-python/importlib_resources/importlib_resources-3.0.0.ebuild
new file mode 100644
index 000000000000..39499d3eb2f2
--- /dev/null
+++ b/dev-python/importlib_resources/importlib_resources-3.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# This is a backport of Python 3.9's importlib.resources
+PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read resources from Python packages"
+HOMEPAGE="https://importlib-resources.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/contextlib2[${PYTHON_USEDEP}]
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ dev-python/singledispatch[${PYTHON_USEDEP}]
+ dev-python/typing[${PYTHON_USEDEP}]
+ ' -2)
+ $(python_gen_cond_dep 'dev-python/zipp[${PYTHON_USEDEP}]' pypy3 python3_{6,7})
+"
+BDEPEND="
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-3.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs dev-python/rst-linker dev-python/jaraco-packaging
+
+python_compile() {
+ distutils-r1_python_compile
+ if ! python_is_python3; then
+ rm "${BUILD_DIR}/lib/importlib_resources/_py3.py" || die
+ fi
+}
+
+python_install() {
+ distutils-r1_python_install --skip-build
+}