summaryrefslogtreecommitdiff
path: root/dev-python/importlib_resources/importlib_resources-1.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /dev-python/importlib_resources/importlib_resources-1.0.2.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'dev-python/importlib_resources/importlib_resources-1.0.2.ebuild')
-rw-r--r--dev-python/importlib_resources/importlib_resources-1.0.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/importlib_resources/importlib_resources-1.0.2.ebuild b/dev-python/importlib_resources/importlib_resources-1.0.2.ebuild
new file mode 100644
index 000000000000..830ec759d0b0
--- /dev/null
+++ b/dev-python/importlib_resources/importlib_resources-1.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read resources from Python packages"
+HOMEPAGE="https://importlib-resources.readthedocs.io/en/latest/"
+SRC_URI="https://gitlab.com/python-devs/${PN}/-/archive/${PV}/${P}.tar.gz"
+LICENSE="Apache-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]"
+
+RDEPEND="${DEPEND}"
+
+python_test() {
+ esetup.py test
+}