summaryrefslogtreecommitdiff
path: root/dev-python/immutables/immutables-0.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-python/immutables/immutables-0.14.ebuild
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-python/immutables/immutables-0.14.ebuild')
-rw-r--r--dev-python/immutables/immutables-0.14.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-python/immutables/immutables-0.14.ebuild b/dev-python/immutables/immutables-0.14.ebuild
new file mode 100644
index 000000000000..ce13a1de3ff4
--- /dev/null
+++ b/dev-python/immutables/immutables-0.14.ebuild
@@ -0,0 +1,17 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="A high-performance immutable mapping type for Python"
+HOMEPAGE="https://github.com/MagicStack/immutables"
+SRC_URI="https://github.com/MagicStack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+distutils_enable_tests pytest