summaryrefslogtreecommitdiff
path: root/dev-python/immutabledict/immutabledict-2.2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-29 11:14:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-29 11:14:34 +0100
commitb83e82c4d46297f4fbe56dc8b6e149637d5d90fd (patch)
tree147ed0e44f1ffb8bfbb03c75e5a308d2138f3884 /dev-python/immutabledict/immutabledict-2.2.4.ebuild
parentdb970551c403ad46231ff09b63717be8c11351d3 (diff)
gentoo auto-resync : 29:04:2023 - 11:14:33
Diffstat (limited to 'dev-python/immutabledict/immutabledict-2.2.4.ebuild')
-rw-r--r--dev-python/immutabledict/immutabledict-2.2.4.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/immutabledict/immutabledict-2.2.4.ebuild b/dev-python/immutabledict/immutabledict-2.2.4.ebuild
new file mode 100644
index 000000000000..e21f2f2b7c13
--- /dev/null
+++ b/dev-python/immutabledict/immutabledict-2.2.4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="An immutable wrapper around dictionaries"
+HOMEPAGE="
+ https://github.com/corenting/immutabledict/
+ https://pypi.org/project/immutabledict/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest