summaryrefslogtreecommitdiff
path: root/dev-python/ijson/ijson-3.2.0_p0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-01 15:26:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-01 15:26:21 +0100
commitd14501acaa1e3634cb0a6f6e356923391009eb46 (patch)
tree6fca6701ec7850e503efaf22370bab079a735dd8 /dev-python/ijson/ijson-3.2.0_p0-r1.ebuild
parent9b9c22874161d13ca8d50c952d549f2390f3f179 (diff)
gentoo auto-resync : 01:06:2023 - 15:26:21
Diffstat (limited to 'dev-python/ijson/ijson-3.2.0_p0-r1.ebuild')
-rw-r--r--dev-python/ijson/ijson-3.2.0_p0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/ijson/ijson-3.2.0_p0-r1.ebuild b/dev-python/ijson/ijson-3.2.0_p0-r1.ebuild
new file mode 100644
index 000000000000..e2f912075f33
--- /dev/null
+++ b/dev-python/ijson/ijson-3.2.0_p0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+MY_P="${P//_p/.post}"
+DESCRIPTION="Iterative JSON parser with a Pythonic interface"
+HOMEPAGE="
+ https://github.com/ICRAR/ijson/
+ https://pypi.org/project/ijson/
+"
+SRC_URI="
+ https://github.com/ICRAR/${PN}/archive/v${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="
+ dev-libs/yajl
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/ICRAR/ijson/commit/e076d8343f63698355fd52dc2d6983fd1c1a745e
+ "${FILESDIR}/${P}-py312.patch"
+)